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Types of data

Types of data

Categorical Numerical

Discrete Continuous

Categorical data represents groups or categories. 

Examples:

1. Car brands: Audi, BMW and Mercedes. 

2. Answers to yes/no questions: yes and no
Numerical data represents numbers. It is divided into two

groups: discrete and continuous. Discrete data can be

usually counted in a finite matter, while continuous is

infinite and impossible to count.

Examples:

Discrete: # children you want to have, SAT score

Continuous: weight, height
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Levels of measurement

Levels of measurement

Qualitative Quantitative

Interval Ratio

There are two quantitative levels: interval and ratio. They

both represent “numbers”, however, ratios have a true

zero, while intervals don’t.

Examples:

Interval: degrees Celsius and Fahrenheit

Ratio: degrees Kelvin, length

Nominal Ordinal

There are two qualitative levels: nominal and ordinal. The

nominal level represents categories that cannot be put in

any order, while ordinal represents categories that can be

ordered.

Examples:

Nominal: four seasons (winter, spring, summer, autumn)

Ordinal: rating your meal (disgusting, unappetizing,

neutral, tasty, and delicious)
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Pareto diagramsPie chartsBar charts
Frequency 

distribution tables

Graphs and tables that represent categorical variables

Frequency distribution tables

show the category and its

corresponding absolute

frequency.
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Bar charts are very common.

Each bar represents a category.

On the y-axis we have the

absolute frequency.
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Pie charts are used when we

want to see the share of an

item as a part of the total.

Market share is almost always

represented with a pie chart.

124 113 98
0%

20%

40%

60%

80%

100%

0

50

100

150

Audi Mercedes BMW

F
re

q
u

e
n

c
y

Sales

The Pareto diagram is a special

type of bar chart where the

categories are shown in

descending order of frequency,

and a separate curve shows

the cumulative frequency.

http://365datascience.com/?utm_source=course_notes_descriptive


Pareto diagramsPie chartsBar charts
Frequency 

distribution tables

Graphs and tables that represent categorical variables. Excel formulas
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Bar charts are also called

clustered column charts in

Excel. Choose your data, Insert

-> Charts -> Clustered column

or Bar chart.
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34%

Pie charts are created in the

following way:

Choose your data, Insert ->

Charts -> Pie chart
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Next slide.In Excel, we can either hard

code the frequencies or count

them with a count function.

This will come up later on.

Total formula: =SUM()
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Pareto diagrams in Excel
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Creating Pareto diagrams in Excel:

1. Order the data in your frequency distribution table in

descending order.

2. Create a bar chart.

3. Add a column in your frequency distribution table that

measures the cumulative frequency.

4. Select the plot area of the chart in Excel and Right

click.

5. Choose Select series.

6. Click Add

7. Series name doesn’t matter. You can put ‘Line’

8. For Series values choose the cells that refer to the

cumulative frequency.

9. Click OK. You should see two side-by-side bars.
10. Select the plot area of the chart and Right click.

11. Choose Change Chart Type.

12. Select Combo.

13. Choose the type of representation from the dropdown

list. Your initial categories should be ‘Clustered

Column’. Change the second series, that you called

‘Line’, to ‘Line’.

14. Done.

http://365datascience.com/?utm_source=course_notes_descriptive


Numerical variables. Frequency distribution table and histogram

Frequency distribution tables for numerical variables are different than

the ones for categorical. Usually, they are divided into intervals of equal

(or unequal) length. The tables show the interval, the absolute

frequency and sometimes it is useful to also include the relative (and

cumulative) frequencies.

The interval width is calculated using the following formula:

𝐼𝑛𝑡𝑒𝑟𝑎𝑙 𝑤𝑖𝑑𝑡ℎ =
𝐿𝑎𝑟𝑔𝑒𝑠𝑡 𝑛𝑢𝑚𝑏𝑒𝑟 − 𝑠𝑚𝑎𝑙𝑙𝑒𝑠𝑡 𝑛𝑢𝑚𝑏𝑒𝑟

𝑁𝑢𝑚𝑏𝑒𝑟 𝑜𝑓 𝑑𝑒𝑠𝑖𝑟𝑒𝑑 𝑖𝑛𝑡𝑒𝑟𝑣𝑎𝑙𝑠
Creating the frequency distribution table in Excel:

1. Decide on the number of intervals you would like to use.

2. Find the interval width (using a the formula above).

3. Start your 1st interval at the lowest value in your dataset.

4. Finish your 1st interval at the lowest value + the interval width. ( = start_interval_cell + interval_width_cell )

5. Start your 2nd interval where the 1st stops (that's a formula as well - just make the starting cell of interval 2 = the ending of interval 1)

6. Continue in this way until you have created the desired number of intervals.

7. Count the absolute frequencies using the following COUNTIF formula:

=COUNTIF(dataset_range,">=“&interval start) -COUNTIF(dataset_range,">“&interval end).

8. In order to calculate the relative frequencies, use the following formula: = absolute_frequency_cell / number_of_observations

9. In order to calculate the cumulative frequencies:

i. The first cumulative frequency is equal to the relative frequency

ii. Each consequitive cumulative frequency = previous cumulative frequency + the respective relative frequency

Note that all formulas could be found in the lesson Excel files and the solutions of the exercises provided with each lesson.
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Numerical variables. Frequency distribution table and histogram

Creating a histogram in Excel:

1. Choose your data

2. Insert -> Charts -> Histogram

3. To change the number of bins (intervals):

1. Select the x-axis

2. Click Chart Tools -> Format -> Axis options

3. You can select the bin width (interval width), number of bins,

etc.

Histograms are the one of the most common ways to represent

numerical data. Each bar has width equal to the width of the interval.

The bars are touching as there is continuation between intervals: where

one ends -> the other begins.
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Graphs and tables for relationships between variables. Cross tables

Creating a side-by-side chart in Excel:

1. Choose your data

2. Insert -> Charts -> Clustered Column

Selecting more than one series ( groups of data ) will automatically

prompt Excel to create a side-by-side bar (column) chart.

Cross tables (or contingency tables) are used to represent categorical variables. One set

of categories is labeling the rows and another is labeling the columns. We then fill in

the table with the applicable data. It is a good idea to calculate the totals. Sometimes,

these tables are constructed with the relative frequencies as shown in the table below.
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Side-by-side bar chart

Stocks Bonds Real Estate

A common way to represent the data from a cross table is by using a

side-by-side bar chart.
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Graphs and tables for relationships between variables. Scatter plots

Creating a scatter plot in Excel:

1. Choose the two datasets you want to plot.

2. Insert -> Charts -> Scatter

When we want to represent two numerical variables on the same graph, we usually use

a scatter plot. Scatter plots are useful especially later on, when we talk about regression

analysis, as they help us detect patterns (linearity, homoscedasticity).

Scatter plots usually represent lots and lots of data. Typically, we are not interested in

single observations, but rather in the structure of the dataset.
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A scatter plot that looks in the following way (down) represents data that doesn’t have

a pattern. Completely vertical ‘forms’ show no association.

Conversely, the plot above shows a linear pattern, meaning that the observations move

together.
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Mean

The mean is the most widely spread

measure of central tendency. It is the

simple average of the dataset.

Note: easily affected by outliers

The formula to calculate the mean is:

In Excel, the mean is calculated by:

=AVERAGE()

Median

The median is the midpoint of the

ordered dataset. It is not as popular as

the mean, but is often used in

academia and data science. That is

since it is not affected by outliers.

In an ordered dataset, the median is

the number at position

If this position is not a whole number,

it, the median is the simple average of

the two numbers at positions closest to

the calculated value.

In Excel, the median is calculated by:

=MEDIAN()

Mode

The mode is the value that occurs most

often. A dataset can have 0 modes, 1

mode or multiple modes.

The mode is calculated simply by

finding the value with the highest

frequency.

In Excel, the mode is calculated by:

=MODE.SNGL() -> returns one mode

=MODE.MULT() -> returns an array

with the modes. It is used when we

have more than 1 mode.

Mean, median, mode

σ𝑖=1
𝑁 𝑥𝑖

𝑁
or

𝑥1 + 𝑥2 + 𝑥3 +⋯+ 𝑥𝑁−1 + 𝑥𝑁
𝑁

n+1

2
.
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Skewness

Median

Mode

Mean

Skewness is a measure of asymmetry that indicates whether

the observations in a dataset are concentrated on one side.

Right (positive) skewness looks like the one in the graph. It

means that the outliers are to the right (long tail to the right).

Left (negative) skewness means that the outliers are to the left.

Usually, you will use software to calculate skewness.

1
𝑛
σ𝑖=1
𝑛 (𝑥𝑖 − ҧ𝑥)3

1
𝑛 − 1

σ𝑖=1
𝑛 (𝑥𝑖 − ҧ𝑥)2

3Formula to calculate skewness:Calculating skewness in Excel:

=SKEW()
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Point 6

Variance and standard deviation

Variance and standard deviation measure the dispersion of a

set of data points around its mean value.

There are different formulas for population and sample

variance & standard deviation. This is due to the fact that the

sample formulas are the unbiased estimators of the population

formulas. More on the mathematics behind it.

Calculating variance in Excel:

Sample variance: =VAR.S()

Population variance: =VAR.P()

Sample standard deviation: = STDEV.S()

Population standard deviation: =STDEV.P()

σ2 = 
σ𝑖=1
𝑁 (𝑥𝑖−𝜇)

2

𝑁

𝑠2 = 
σ𝑖=1
𝑛 (𝑥𝑖− ҧ𝑥)2

𝑛−1

Population variance formula:

Sample variance formula:

Sample standard deviation formula:

Population standard deviation formula:

𝑠 = 
σ𝑖=1
𝑛 (𝑥𝑖− ҧ𝑥)2

𝑛−1

σ = 
σ𝑖=1
𝑁 (𝑥𝑖−𝜇)

2

𝑁
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Covariance and correlation

Covariance is a measure of the joint variability of two variables.

➢ A positive covariance means that the two variables move

together.

➢ A covariance of 0 means that the two variables are

independent.

➢ A negative covariance means that the two variables move in

opposite directions.

Covariance can take on values from -∞ to +∞ . This is a

problem as it is very hard to put such numbers into perspective.

Sample covariance formula:

Population covariance formula:

In Excel, the covariance is calculated by:

Sample covariance: =COVARIANCE.S()

Population covariance: =COVARIANCE.P()

Correlation

Correlation is a measure of the joint variability of two variables.

Unlike covariance, correlation could be thought of as a

standardized measure. It takes on values between -1 and 1, thus

it is easy for us to interpret the result.

➢ A correlation of 1, known as perfect positive correlation,

means that one variable is perfectly explained by the other.

➢ A correlation of 0 means that the variables are independent.

➢ A correlation of -1, known as perfect negative correlation,

means that one variable is explaining the other one

perfectly, but they move in opposite directions.

Sample correlation formula:

Population correlation formula:

In Excel, correlation is calculated by:

=CORREL()

Covariance

𝑠𝑥𝑦 = 
σ𝑖=1
𝑛 𝑥𝑖− ҧ𝑥 ∗(𝑦𝑖−ത𝑦)

𝑛−1

𝜎𝑥𝑦 = 
σ𝑖=1
𝑁 𝑥𝑖−𝜇𝑥 ∗(𝑦𝑖−𝜇𝑦)

𝑁
ρ =

𝜎𝑥𝑦

𝜎𝑥𝜎𝑦

r =
𝑠𝑥𝑦

𝑠𝑥𝑠𝑦
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