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Module Overview 
This module looks at how to turn data into eye-catching charts using Microsoft® Excel® 2016. One of the 
reasons that Excel is such a popular tool for data analysis is that you can very easily create colorful charts 
from your data. In this module, we consider some of the charts available in Excel, and how to use them. 

Objectives 
After completing this module, you will be able to: 

 Create charts from data in Excel. 

 Filter data, and format charts. 

 Create Sparklines. 

 Choose the most appropriate chart for your needs. 
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Lesson 1 
Introducing Excel Charts 

Charts make it easier to understand what data means; they are helpful whilst working with data, and when 
presenting conclusions. Charts bring numbers to life, graphically showing proportions, trends, and 
comparisons. They add color and interest to reports and presentations. 

This lesson looks at Excel charts, and how to use them. 

Lesson Objectives 
After completing this lesson, you will be able to: 

 Create a chart from data supplied to you. 

 Understand the different chart types available in Excel. 

 Select an appropriate chart type for your needs. 

Creating a Chart 

A chart is a graphical representation of data. A 
chart uses lines, bars, segments, or other graphics 
to show the relationship between data values. 
Charts normally have an X and Y axis, with the X 
axis on the horizontal, and the Y axis on the 
vertical.  

Seeing Data Graphically 
As a business person, you often need to see data 
at different levels of detail. At the top level, you 
want to identify trends and anomalies, such as 
differences between sales totals by divisions or 
whether this year’s results are better than last 
year’s. Presenting data as a chart enables a lot of information to be understood quickly, and for 
discrepancies to be identified at a glance. Having seen the high-level view, and identified what needs 
further investigation, you can then look at the data in more detail. 

Charts are not so good, however, for seeing precise data values. A chart is good for quickly highlighting 
the fact that one division performed a lot better than another division, but you need the numbers to see 
the exact sales amounts. When there is a lot of data in a report, comparisons might not be so noticeable, 
so it is a good idea to use a combination of approaches. Using charts to present data in a “top-down” way 
is highly effective in communicating complex data. 

 How to Create a Chart in Excel 
1. Highlight the data you want to use to create a chart. 

2. From the Insert menu, click the lower right arrow to see all the available chart types. 

3. Select either the Recommended Charts, or All Charts tab. 

4. From the left-hand panel, select the type of chart you require. 

5. From the right-hand panel, select the specific chart you require. 
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6. Click OK. The chart is inserted into the workbook. 

Style and Color of Charts 

After you have created your chart, and chosen the 
type, such as a pie chart or an area chart, you can 
then refine the presentation by selecting the 
correct style and colors for your chart. You can 
finish off by making your chart look attractive, or 
ensuring it is displayed in your corporate colors. 

Chart Styles 
Each chart type, such as pie, line, bar, column, and 
so on, has a number of different styles associated 
with it. There are three ways of seeing the styles 
associated with a particular chart type: 

1. Highlight the data, click the Insert tab, and then click the down arrow on the Charts group to 
display the Insert Chart selection dialog box.  Select the All Charts tab, click the chart type from the 
left-hand panel, and see the chart styles displayed on the right. Click a chart style to see a preview of 
your chart. 

2. Highlight the data, click the Insert tab, and then click the down arrow next to one of the chart types 
displayed in the Charts group. A graphical list of the available chart types is displayed. 

3. Highlight an existing chart, and click Chart Styles (a paint brush). A list of all the available chart styles 
for that chart type is displayed. You can also select colors for your chart from this menu. 

Chart Colors 
To select a predefined colorway for your chart, select the chart, click the Chart Styles icon and click the 
Color tab. Several colorful combinations are displayed, in addition to a number of monochromatic 
combinations. Click the color combinations to select one.  

    Note: The colorways are displayed when you click Chart Styles. These are based on the 
colorway used by the workbook. To change the workbook colorway, click the Page Layout tab, 
click Colors, and select the color palette you want to work with. Note that the color palette will 
then be changed for everything within the workbook. 

Save As a Template 
If you want to standardize on a particular chart type, style, and colorway, you can save a template. To 
create a chart template: 

1. Create a chart and format it in the style, and colorway you require. 

2. Right-click the chart and select Save as Template. 

3. Type a file name for the template. 

4. Either specify a folder for the template, or accept the default. 

5. Click Save. The template is created. 
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To Use a Saved Template 
After you have created one or more templates, they are then available to use from the Insert/Change 
Chart Type dialog box. To use a saved template: 

1. Highlight your data. 

2. Click the Insert tab. 

3. From the Charts group, either click the bottom right arrow, or click Recommended Charts to 
display the Insert Chart dialog box. 

4. Select the All Charts tab. 

5. From the left-hand pane, select the Templates folder. A preview of your chart is displayed in the 
right-hand pane, using your named templates. 

6. Click the template you want to use and click OK. 

    Best Practice: If you are displaying a number of charts in the same presentation or report, 
use the same style and colorway for all of them. Although it is tempting to use different colors or 
styles to make something stand out, your presentation will be easier to read if they all follow the 
same style.  

Formatting a Chart 

You can easily create a chart by highlighting the 
data and selecting a suitable chart type. After the 
chart is created, however, you might want to make 
some changes so it’s easier to understand. 

Amending the Title 
To change the title of the chart, double-click the 
label called Chart Title. Overtype the name of 
your chart.  

Adding Axis Titles 
A common requirement is to add titles to the X 
and Y axis. To add titles, highlight the chart, select 
Chart Elements (+), and click the box next to Axis Titles. Label boxes appear on the chart next to each 
axis. Double-click the label to type the correct axis title. 

Adding or Removing Chart Elements 
You can add or remove elements from a chart by clicking Chart Elements (+) when the chart is selected. 
A list of chart elements appears with a tick against elements that are currently displayed on the chart. 

If you want to remove gridlines from the chart, for example, click Chart Elements to display the menu, 
and then select the Gridlines box. If you change your mind, and want gridlines to appear, click the box 
again to clear gridlines. 
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By selecting the chart, and clicking Chart Elements, you can add, remove or amend the following chart 
elements: 

 Axes: add or remove vertical and horizontal axes. Click the > arrow to choose to have only the 
horizontal, or vertical axis. Click More Options for formatting options, such as the width and color of 
the axis lines. 

 Axis titles: add or remove axis titles. Click the > arrow to choose only a horizontal or vertical title. 
Click More Options for formatting options, such as the color of the axis title, or alignment. 

 Chart title: add or remove the chart title. Click the > arrow to select the position of the title, and click 
More Options for formatting options, such as the color of the chart title, and text style. 

 Data labels: add or remove data labels. Click the > arrow to select the position of the data labels. 
Click More Options to format the numbers or borders. 

 Data table: adds the data values to the chart. Click the > arrow to select with or without legend. Click 
More options to format the borders and fill lines around the data table. 

 Error bars: add or remove error bars. Click the > arrow to select Standard Error, Percentage or 
Standard Deviation. Click More Options to format the error bars. If you want to know how Microsoft 
calculate the error amounts, see the link that follows. 

 Gridlines: adds or removes the gridlines from the chart. Click the > arrow to select the type of 
gridlines you want. Click More Options to format the gridlines. 

 Legend: adds or removes a legend from the chart. Click the > arrow to select the position of the 
legend. Click More Options to format the legend. 

 Trendline: adds or removes a trendline. Click the > arrow to select the type of trendline or moving 
average you require. Choose from Linear, Exponential, Linear Forecast, or Two Period Moving 
Average. Click More Options to format the trendline. There are additional trendline options, plus 
options for displaying the trendline. 

The exact options shown depend on the chart type. 

Error Bars 
For more details on how Microsoft calculate the error amounts for error bars, including the equations, see 
Office support documentation: 

Add, change, or remove error bars in a chart 

https://aka.ms/nlxg9c 
 

    Best Practice: If you want to display exact values on your chart, either select data labels to 
show the values on the chart graphics, or select a data table to provide data separate from the 
chart. One or other is sufficient—do not use both together. 

Why Add a Trendline? 
A trendline shows the general, or average, direction of the data over time. A straight line representing the 
data is overlaid onto the chart. Whilst a chart follows the fluctuations of the data, the line fits as closely as 
possible to the data, giving the effect of evening out fluctuations within the data.  

For example, a person’s weight might be measured and displayed day by day. A trendline shows the 
general direction, either up or down, over time. You can also extend the trendline forwards, based on the 
data. Not all chart types are suitable for trendlines. Use a trendline with bar, column and area charts, and 
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also with stock, scatter and bubbles charts. You cannot add trendlines to pie charts, stacked, 3-D or 
surface charts, or to doughnut charts. 

The line represents the best fit through the data—to see how well the trendline represents the underlying 
data, you have the option to show the R-squared value on the chart. When the R-squared value is close to 
1, the trendline is a good fit to the data. Select the Display R-squared value on chart box if you want to 
show this value on your chart.  

Trendlines are a great way of providing high-level information, making it easy for someone to interpret 
the data you are presenting. 

For more information about trendlines, how to choose the best type of trendline for your data, and how 
trendlines are calculated, see the Office support documentation: 

Add a trend or moving average line to a chart 

https://aka.ms/ipoy1n 

Choosing a Chart Type 

There are a number of different chart types 
available in Excel. As you have seen, producing the 
chart is quite easy. However, choosing the correct 
chart type for the data, and your audience, 
requires a little thought. In this topic, you will 
consider the different chart types available, and 
when each one might be used. 

Excel includes the following different categories of 
chart types: 

 Line charts 

 Column charts 

 Pie charts 

 Bar charts 

 Area charts 

 Scatter charts 

 Stock charts 

 Surface charts 

 Radar charts 

 Treemap  

 Sunburst 

 Histogram 

 Box and whisker 

 Waterfall 

In addition, you can combine chart types to show one set of data using one type of chart, and another set 
of data using a different chart type. 
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However, some chart types are better than others for representing data. The best chart type depends on 
your data. 

Recommended Charts  
Excel will recommend one or more chart types, depending on your data. To see which chart types Excel 
recommends for your data: 

1. Highlight the data. 

2. Select the Insert tab, and click Recommended Charts. 

3. One or more recommended chart types will be displayed in the left-hand pane. The right-hand pane 
shows your data represented using the recommended chart type, together with an explanation of 
why that chart type has been chosen. There is often more than one recommended chart type, so click 
each one to see the preview chart.  

4. If you don’t want to use one of the recommended chart types, you can click the All Charts tab, and 
select a different type. 

5. When you have decided which chart type to use, click OK. The chart will be inserted into the 
workbook.  

Selecting an Appropriate Chart Type 
It is worth considering which type of chart you use, because different chart types give very different 
representations of the data. A well designed chart will add clarity to the data, whereas the wrong chart 
type will make it more difficult to understand the data. This section discusses a few of the more popular 
chart types, and the type of data they are suited to. 

Pie Charts 
Pie charts are one of the most popular chart types. Like the pies they represent, they show parts of a 
whole. Consider a school describing the after school activities of their children. A pie chart would be good 
at showing that, for example:  

 55 percent of children play football. 

 25 percent of children do not partake in after school activities. 

 15 percent of children go to music lessons. 

 5 percent of children attend the school’s drama group. 

Pie charts work well with fewer categories, and when the categories make up a significant percentage of 
the whole. Many small segments can be difficult to interpret. Occasionally, however, you can make a 
dramatic statement using a small segment to emphasize a point. Consider the same school, but this time 
showing the age ranges of children taking part in after school activities: 

 67 percent of children using after school facilities are aged 15 years or older. 

 26 percent of children are aged 11-14. 

 6 percent of children are aged 9-11. 

 1 percent of children are aged 5-8. 

This pie chart would dramatically illustrate the difficulty of including younger children in after school 
activities. 

Two pie charts together can be an effective way of showing the different proportions between two or 
more sets of data—perhaps the different after school data sets of two schools. In this case, ensure that the 
data is in the same sequence and the same colors are used for each data segment for easy comparison.  
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Excel has both 2-D and 3-D pie charts, including “exploding” pie charts, where the segments are not 
contiguous. Select More Options to investigate setting the angle of the first slice—to make more than 
one pie chart easier to read—and point explosion.  

Column and Bar Charts 
Column and bar charts are another common chart type, mainly because they are so versatile. They are 
good for showing the relative size of one data set to another, and can accommodate many different 
values within the same chart. In Excel, a bar chart shows bars on the horizontal, and a column chart 
displays vertical. Column charts are better suited to charts with many bars, because the labels are easier to 
read. Column charts with vertical bars suit charts with few bars, and shorter labels. 

Clustered column and bar charts are effective at showing comparisons, such as the monthly sales figures 
of two divisions, or annual sales by region for a number of years. You can easily see differences, and they 
provide a lot of information in a small space. 

Variations on column and bar charts include stacked column or bar charts, and 3-D charts. Stacked 
column and bar charts include data for more than one data set in the same bar; 3-D column and bar 
charts are a visually striking way of presenting data, perhaps more suitable when you don’t have many 
charts to present together. 

Line Charts 
Line charts can be used to represent many types of data, but are particularly effective in showing trends 
over time. A line going in an upwards direction, or a line going in a downwards direction both offer 
compelling stories. Consider a line graph if you want to highlight the price of something increasing over 
time; or the number of children passing exams over time; or the sales for a company or division over time. 
You can have a few different data sets on the same chart, each represented by a line in a different color. 
This is particularly effective when the lines are far apart, perhaps showing the direction in prices for high-
priced items, mid-range items, and low-priced items. Avoid showing data sets with similar values using a 
line chart, because having too many lines close together can be difficult to read.  

Consider combining a line chart with a bar chart to show data sets that are not comparable, but have 
similar values. This might work for sales totals by month shown as a bar chart, with a line chart showing 
gross profit by month. Although the gross profit will be much lower than the sales figures, this would be 
well understood by a business audience, and provides valuable additional information in the same chart. 
To create this chart, select the Combo chart type in All Charts, and then select the bar and line 
combination. 

Area Charts 
Area charts use solid blocks of color to represent data values, and so can be visually attractive. Area charts 
work best when two or more data sets are a different order of magnitude, such as sales and gross margin. 
The gross margin is displayed as a smaller area, overlaid on top of the larger area of sales.  

Area charts work less well when data sets are unpredictable, and one data point is obscured by another. 
Excel gets round this problem by allowing you to set a level of transparency—but be sure that the final 
result is clear.  

Treemap 
This is a new chart type that is suitable for showing data in hierarchies.  
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Demonstration: Turning Data into Charts 

Demonstration Steps 
Prepare the Environment 

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd. 

2. Start Excel 2016.  

3. Click Blank workbook. 

4. Click File, Open, and then open Demo1.xlsx file in D:\Demofiles\Mod01.   

Create a Chart 

1. Highlight from cell A2 to C12. 

2. Click the Insert tab. 

3. In the Charts group, click Recommended Charts. 

4. Browse the recommended chart types by clicking on each chart type and displaying the chart 
preview.  

5. Click the Scatter chart and discuss why this would be an inappropriate chart to use for this data. 
(Sales and profit data sets are treated the same, even though they are different—also, no relationship 
is shown between the two.) 

6. Click the Clustered Column chart type and discuss why this would be appropriate. (Clear relationship 
between sales and profit, plus differences between regions.) 

7. Click two more chart types and discuss with the class whether or not these chart types would be 
suitable for the data. 

8. Click Clustered Column, preview the chart, and then click OK. The chart will be inserted into the 
workbook.  

Format the Chart 

1. Double-click the chart title, highlight the words Chart Title, and type Adventure Works 2014 
Results. Click somewhere on the workbook to display the new title. 

2. Click somewhere on the chart, and click Chart Elements. 

3. Select the Trendlines box. When prompted, select Sales and click OK. 

4. Click the chart, and click Chart Elements, and then click the arrow next to Trendlines. Note the 
different types of trendlines.  

5. Click More Options. The Format Trendline options appear. 

6. Click Display R-squared value on chart. 

Resize and Position the Chart 

1. Resize the chart to make it larger by clicking and dragging a corner. 

2. Position the chart to a suitable place on the workbook. 

3. Close the workbook without saving. 

4. An example chart is in the Demo1 Chart.xlsx file in the Solution folder. 
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Question: Think of some data presentations that you have seen recently. Which ones 
presented data in an easily understandable way? Which ones were difficult to understand?  

What was it about the good presentation that made the data meaningful? 
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Lesson 2 
Filtering and Formatting Data 

Many business managers rely on reports generated by the IT department to get the raw data they require. 
If you need to present a lot of data, it can be time consuming to ask for different variations of the data, 
formatted in different ways. It can be more efficient to ask the IT department to generate a report with all 
the data you need, so that you can filter and format it yourself.  

In this lesson, you will look at how you can filter and format data, so that you can present charts in the 
way you want. 

Lesson Objectives 
After completing this lesson, you will be able to: 

 Filter data to display only rows that should be included in the chart. 

 Format data correctly. 

Filtering Data 

Adding a filter to your data means you can select 
certain rows for inclusion in your chart, without 
changing the underlying data. By adding a filter, 
you do not change the data, nor do you remove 
rows. You can use the filter to select what you do 
or do not want for each chart you produce. 

When you work in Excel, filtering data is useful in 
many ways, and not only when producing charts. 
In this topic, you will see how to use filters to 
create relevant charts. 

Adding a Data Filter 
You can add a filter to a data set by: 

1. Highlighting the data. 

2. Selecting the Data tab. 

3. Clicking Filter. An arrow symbol appears at the top of each column. 

To apply a filter, click the filter arrow, and select the rows you want to display. The options shown on the 
filter menu change depending on the data, but include text filters, and number filters, with options to 
show the top n records. When a filter has been applied, a small dot appears next to the filter arrow. You 
can apply more than one filter criterion to one set of data. 

To remove a filter, click the filter arrow, and select Clear Filter.    

Hiding Columns 
Hiding columns enables you to create charts from the original data, without the need to cut and paste. 
Although it is not necessarily time consuming to remove columns by cutting and pasting, it often leads to 
errors. By hiding columns, the original data stays intact, and the columns can then be displayed again 
when needed. 
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To hide one or more columns: 

1. Highlight the column(s). 

2. Right-click and select Hide. 

When you want to display the column(s) again, highlight the columns adjacent to the hidden columns(s), 
right-click and select Unhide. 

Formatting Data 

Formatting data includes formatting number 
columns as currency, percentages, or rounding 
values. The advantage of formatting the raw data 
is that it is then correct in every chart you produce, 
so you only have to format it once. It also makes 
the meaning of the data clear. 

Formatting Data 
To format data, select the cells you want to 
format, click the Home tab, and then format the 
data using the Number group. You can format 
numbers as currency, percentages, add or remove 
separators, and set the correct number of decimal 
places. The formatting will then be reflected in charts, and data tables in your charts. 

Formatting Dates 
Dates are stored internally as numbers, but you can format them as short or long dates in a worksheet or 
for a chart. If you format a date value as a number, you will see the internal value held in Excel. This 
enables Excel to do calculations, such as the number of days or weeks between two dates.  

    Best Practice: Although you can easily change the format of a value, it is good practice to 
format values correctly. This makes it easier to check your data, and reduces the possibility of 
introducing errors. Working in a tidy manner always pays dividends. 

How to Format Data 
1. Select the cell you want to format. 

2. From the Home tab, go to the Number group.  

3. Select the number style you want to use. 

4. If the format you want is not displayed, click the diagonal arrow to display the format cells dialog box. 
Make your selection and click OK.  

Alternatively, right-click a cell and select Format Cells. 
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Demonstration: Selecting Relevant Data 

In this demonstration, a business manager working for Adventure Works Cycles has been asked to 
produce a report of sales for all territories in the USA. She had previously asked the IT department for a 
report of all Adventure Works Cycles’ territories. In the demonstration, we will see how she filters and 
formats the data, before producing the charts required for her report. 

Demonstration Steps 
Prepare the Environment 

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd.  

2. Start Excel 2016.  

3. Click Blank workbook. 

4. Click File, Open, and open Demo2.xlsx file in D:\Demofiles\Mod01. 

Filtering the Data 

1. Highlight the data from cell A2 to N12. 

2. Click the Data tab, and then click Filter. Small arrow buttons appear at the top of each column of 
data. 

3. Click the down arrow next to Code and inspect the filter menu. Note that the menu allows the rows 
to be sorted, or filtered on specific text, or selected using the check boxes.  

4. Click (Select All) to remove the ticks from all boxes. 

5. Click the US box to select US records, and then click OK. Note that only rows relating to US results are 
displayed. 

Hiding Data Columns 

1. Highlight columns C and D. 

2. Right-click the selection and click Hide. The two columns are hidden. 

Formatting Data 

1. Select cells E3 to F12. 

2. Click the Home tab, and click the down arrow next to the currency symbol.  

3. Select English (United States) to format the numbers as dollars.  

4. Click decrease decimal twice to format the data to no decimal places. 

Create a Chart with Revised Data 

1. Select cells B2 to F12. 

2. Click the Insert tab. 

3. Click Recommended Charts and select the Clustered Column chart. Click OK. 

4. Overtype Chart Tile to rename the chart Proseware Results Year on Year. 

5. Click Chart Elements and select Data Table. The data values are displayed on the chart correctly 
formatted. 

6. To see the data formatted data, with an example chart, see Demo2 Formatted.xlsx in 
D:\Demofiles\Mod01\Solution. 
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7. Close Excel without saving the workbook. 

Verify the correctness of the statement by placing a mark in the column to the right. 

Statement Answer 

True or false? It is important to format 
data correctly to prevent errors in your 
analysis. 
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Lesson 3 
Sparklines 

Sparklines are mini charts that fit into a single cell. They are a great way of illustrating a point, without 
taking up too much space.  

Lesson Objectives 
After completing this lesson, you will be able to: 

 Add a sparkline to your worksheet.  

 Choose the correct sparkline for your needs. 

 Remove a sparkline from your worksheet. 

 Format a sparkline. 

Sparklines 

Sparklines look like very small charts that fit into a 
single cell. Although they are small, they can tell a 
big story. Sparklines were introduced with 
Microsoft Excel 2010, and add understandability 
and color to reports. Sparklines let you see data 
visually, but in a tiny space.  

What Is a Sparkline? 
Sparklines are not chart objects, even though they 
look like tiny charts. Sparklines are simple chart 
graphics displayed in the background of a cell. 
This means that you can enter text in the same cell 
that contains the sparkline, and the text will 
display on top of the sparkline. Each sparkline represents a row of data. 

There are three types of sparkline: 

 Line. Similar to the line chart type. 

 Column. Similar to the bar or column chart type. 

 Win/Loss. Suitable for highlighting positive and negative numbers. 

Create a Sparkline 
1. To create a sparkline, click the Insert tab, and select a sparkline from the Sparklines group. The 

Create Sparklines dialog box appears. 

2. Either enter the data range you want to use, or click the data range icon and select the cells 
containing your data. When you have finished, click the data range icon again. 

3. Either enter the cell reference where you want the sparkline to be displayed, or click the data range 
icon and select the cell where you want the sparkline to be displayed. 

4. Click OK.  
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To Remove a Sparkline 
If you have a sparkline that you want to delete: 

1. Right-click the cell that contains the sparkline. 

2. Click Sparklines, and then click Clear Selected Sparklines. 

Using Sparklines 
Sparklines illustrate patterns in data, drawing the eye to specific points of interest within the data. They 
make patterns and trends easier to see, and encourage people to look at the data that generated a 
sparkline. Like charts, they encourage engagement with the data by illustrating patterns. 

    Best Practice: You can display a sparkline anywhere in a workbook—it is good practice to 
display sparklines close to the data they illustrate. This makes it easier for people to understand 
the data, and how the sparkline was generated. 

For more information about sparklines, see the Office support documentation: 

Use sparklines to show data trends 

https://aka.ms/yyox1z 

Formatting Sparklines 

After creating a sparkline, select it to display 
Sparkline Tools on the menu. The Design tab 
gives you options to format your sparklines. There 
are five groups on the Design tab: 

 Sparkline 

 Type 

 Show 

 Style 

 Group 

    Note: Sparklines can be grouped together 
so that they can be formatted together. Create a sparkline group in the Sparkline Tools Design 
tab.  

Sparkline 
The Edit Data option enables you to change the range of data used for sparklines, and the position of 
sparklines. Click the down arrow to display the following options: 

 Edit Group Location & Data. You can amend the data range and location for a group of sparklines. 

 Edit Single Sparkline’s Data. You can amend the data range and location for a single sparkline. 

 Hidden & Empty Cells. You can specify how empty cells should be handled, and whether or not data 
in hidden rows and columns should be included in the sparkline.  
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Type 
All three sparkline types are displayed, meaning you can change the sparkline type for a specific sparkline, 
or for a sparkline group. 

Show 
You can draw attention to specific parts of the data using the options in this group: 

 High Point. Highlights the highest value with a different color.  

 Low Point. Highlights the lowest values with a different color.  

 Negative Points. Highlights negative values with a different color. 

 First Point. Highlights the first value with a different color. 

 Last Point. Highlights the last value with a different color. 

 Markets. Adds a marker for each data point. Used only with line graphs.  

Style 
You can use the style group to select colors, color intensity, and specific colors for highlighting data. 

 Style gallery. You can select the style and color intensity for your sparkline. 

 Sparkline Color. Select a specific color from the palette, or choose a custom color. 

 Marker Color. You can specify a color for each different type of highlight, such as high point, low 
point, and so on. 

Group 
You can use the Group group (!) to group several sparklines together by highlighting them, and clicking 
Group. If you want to ungroup a number of sparklines, select the group, and then click Ungroup. 

To delete a single sparkline, or a group of sparklines, highlight the relevant sparkline(s) and click Clear. 

Use the Axis option to: 

 Format the vertical axis for a single sparkline, or a group. This means you can define the same axis for 
many sets of data, allowing comparisons to be made against a standard.  

 Set minimum and maximum values for sparkline axes. 

 Specify whether the bars or lines are displayed from left to right, or right to left.  

Demonstration: Adding Sparklines 

Demonstration Steps 
Prepare the Environment 

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd. 

2. Click File, Open, and open Demo3.xlsx file in D:\Demofiles\Mod01. 

Add Sparklines 

1. Click in cell G4. 

2. Click the Insert tab, and in the Sparklines group, click Column. The Create Sparklines dialog box 
appears. 
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3. Click the Data Range icon and select cells C4 to F4. Click the Data Range icon again to enter the 
selection. 

4. Note that the Location Range is G4 because that cell was already highlighted. 

5. Click OK. 

6. Repeat steps 1 to 5, this time with cell G2 selected and the data range C5 to F5.  

7. Highlight cells G4 and G5, click   on the bottom right of the cells, and then drag to cell G13. A 
sparkline is created for each row. 

8. Note how the sparklines highlight the differences between results for each year. 

Create Win/Loss Sparklines 

1. Click in cell H4. 

2. On the Insert tab, in the Sparklines group, click the Win/Loss icon. The Create Sparklines dialog 
box appears. 

3. Click the Data Range icon and select cells C4 to F4. Click the Data Range icon again to enter the 
selection. 

4. Note that the Location Range is H4, because the cell is already selected.  

5. Click OK.  

6. Click the  on the bottom right of the cell, and drag to H10. A win/loss sparkline is created for each 
row. 

7. Note how the win/loss sparkline highlights the losses in the results. 

Formatting a Sparkline 

1. Highlight cells G4 to G10. 

2. Click Group to group them together. 

3. Click Line in the Type group. Notice how all the sparklines are changed to the new type.  

4. Click High Point in the Show group. 

5. Click Marker Color in the Style group. Click High Point and select a bright color. 

6. Click Axis in the Group group, and select Plot Data Right-to-Left. 

7. Close the worksheet without saving. 

8. An example of formatted sparklines is in the Solution folder. 
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Check Your Knowledge 

Question 

Which option is available to format a sparkline? 
 

Select the correct answer. 

 Formatting a sparkline as a pie. 

 Highlighting the highest value in the data set. 

 Adding a pattern to sparkline bars. 

 Showing values on a sparkline. 

 Linking sparklines to data in a SQL Server 
database. 
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Lab: Presenting Data in Charts 
Scenario 
Sindy, the new VP of Marketing, has joined the Adventure Works Cycle company. You have been asked to 
provide some sales data to introduce her to the company. As it is her first day, you decide to present the 
information as a number of charts. 

Objectives 
After completing this lab exercise, you will be able to: 

 Filter data to include only relevant data. 

 Format data correctly. 

 Choose the chart format most appropriate for your needs. 

 Format charts in line with your company’s branding. 

Estimated Time: 60 minutes 

Virtual machine: 10994B-MIA-BI 

User name: Admin 

Password: Pa55w.rd 

Exercise 1: Filtering Excel Data 

Scenario 
You work in the marketing department of the Adventure Works Cycle Company. After the VP of 
Marketing retired last month, the company has hired Sindy, an experienced marketing professional, who 
is expected to turn around the fortunes of the company. You have been asked to prepare some basic sales 
information to show her on her first day. You receive an email from the IT department with the data you 
requested. You now need to create some charts for your meeting with Sindy. 

The main tasks for this exercise are as follows: 

1. Filter Data 

  Task 1: Filter Data 
1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 

Pa55w.rd.  

2. In the D:\Labfiles\Lab01\Starter folder, open the Lab1.xlsx spreadsheet. 

3. Filter the Revenue by Territory data that is suitable for the European report. 

4. Filter again, this time for data that is suitable for the USA report. 

5. Filter again, this time for data that is suitable for the Rest of the World report. 

6. Remove the filter icon from the Revenue by Territory data range. 

7. If you have time, practice adding and removing a filter to the Revenue by Year data. 

8. Save the spreadsheet and leave it open for the next lab exercise. 
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Results: After completing this exercise, you will be able to: 

Identify the data you need for your report. 

Filter the data based on your requirements. 

Exercise 2: Formatting Excel Data 

Scenario 
As you study the data more carefully, you realize that the revenue figures have not been correctly 
formatted. You decide to practice formatting data so that when you create the charts, each chart will 
appear correctly.  

The main tasks for this exercise are as follows: 

1. Formatting Data 

  Task 1: Formatting Data 
1. In the data range titled Revenue by Year, format the different values as follows: 

1. Values as currency to no decimal places. 

2. Totals as currency to no decimal places, and bold. 

3. Percentage values as percent.  

4. Format the values in Revenue by Category appropriately. 

5. Format the values in Revenue by Territory appropriately. 

6. Save the spreadsheet and leave it open for the next lab exercise. 

 

Results: After completing this lab exercise, you will be able to: 

Identify data that is not formatted correctly. 

Format numeric data appropriately. 

Exercise 3: Creating Excel Charts 

Scenario 
You are feeling a little more confident now that you can filter and format the data as you want it. But with 
only an hour to go before your meeting with Sindy, you want to create some charts to bring the data 
alive, and make it easy for her to understand your presentation. 

The main tasks for this exercise are as follows: 

1. Create Charts 

2. Formatting Charts 

  Task 1: Create Charts 
1. Select the data range for Revenue by Category and click Recommended Charts to view the 

different charts recommended by Excel. 

2. Create a pie chart from the Revenue by Category data. 
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3. Select the data range for the Revenue by Year data and create a Clustered Column chart. 

4. Select the data range for Revenue by Territory and filter it so that only USA territories are displayed.  

5. Select the data range for Revenue by Territory and create a bar chart. 

6. Save the spreadsheet and leave it open for the final lab exercise. 

  Task 2: Formatting Charts 
1. Format the Revenue by Territory chart: 

1. Rename the title to Revenue by Territory. 

2. Display the data values on the chart. 

3. Display a trendline on the chart. 

4. Format the Revenue by Year chart: 

1. Rename the title to Revenue by Year. 

2. Filter the data so that only the four most current years are displayed. 

3. Change the colorway for the chart to orange monochromatic. 

4. Format the Revenue by Category chart: 

a. Move the two small slices (accessories and clothing) out a little to give them emphasis. 

b. Show percentage values in white on each slice of the pie. 

c. Change the colorway for the chart to orange monochromatic to match the Revenue by Year 
chart. 

5. Save changes and compare your spreadsheet with the one in the Solution folder. 

 

Results: After completing this lab exercise, you will be able to: 

Choose an appropriate chart for your data. 

Create a chart. 

Format a chart. 
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Check Your Knowledge 

Question 

You want to create a chart to show revenue by 
product category and year. Which chart type is 
suitable? 
 

Select the correct answer. 

 Pie chart 

 Clustered column chart 

 Line chart 

 Radar chart 

 Area chart 
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Module Review and Takeaways 
In this module, you have learnt how to filter data, and format it in preparation for creation charts. You 
have also learnt about the different chart types available in Excel, and how to choose the best chart type 
for the data.  

Learning to work neatly with data pays dividends, and this module has covered some basics that will help 
you do just that: 

 To get the data set you want, use the filter option. Don’t copy and paste data, and make sure you 
delete unwanted rows. Having multiple copies of your data will lead to errors. 

 Format data appropriately, even if it is only for your own benefit. Properly formatted data is easier to 
understand, and makes it less likely that you will make mistakes. 

 Use charts to visualize the data. Visuals are easier to work with, and help you dig deeper into the 
analysis. 

Review Question(s) 
Question: What have you learnt in this module that you can apply to working with your own 
data? What will be most helpful and why? 
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Module Overview 
As managers are faced with more data than ever before, it is important to have a fast way of analyzing it. 
Microsoft® Excel® tables provide a fast and efficient way of understanding a large amount of data.  

This module explores Excel tables; what they are, and how to use them.  

Objectives 
After completing this module, you will be able to: 

 Describe what an Excel table is, and how it is useful. 

 Create an Excel table. 

 Use Excel tables for summarizing data. 

  



2-2 Excel Tables 

Lesson 1 
Introducing Excel Tables 

This lesson introduces Excel tables, describing what they are and how they are useful. 

Lesson Objectives 
When you have completed this lesson, you will be able to: 

 Describe the benefits of using Excel tables. 

 Create and delete an Excel table. 

 Identify the elements of an Excel table. 

Benefits of Excel Tables 

What Is an Excel Table? 
An Excel table is a range of data that has been 
formatted to make it easier to analyze the data. It 
looks much like data in an Excel workbook, but 
with additional formatting. However, an Excel 
table has additional features that make data 
analysis easier.  

What Does an Excel Table Look Like? 
When you create an Excel table, your data 
immediately looks different. When you create an 
Excel table, your data is formatted with: 

1. Row shading on the data, making it easier for the eye to follow rows across many columns, so it’s 
less likely you that will make a mistake. 

2. Filters on each column, encouraging you to filter and sort the data in different ways. 

3. Header shading, which both improves the overall look of the data range, and makes it easier to 
distinguish between header titles, and the data. 

The formatting of an Excel table is designed to help with data analysis, not just to make the data look 
pretty (although it does that, too). Well formatted data is easier to read, easier to understand, and allows 
you to start work on analyzing the data. Badly formatted data, on the other hand, is difficult to read, and 
difficult to understand, as anyone who has worked with poor quality data knows too well. The benefit of 
creating an Excel table is that you will have well formatted data to work with, enabling you to get on with 
the analysis. 

Why Create an Excel Table? 
When you create an Excel table, all the data within the table is treated as a range, similar to a named 
range but with more functionality. This means that if you want to change the formatting, for example, you 
don’t have to select the range again—Excel knows that you want to format the table. 

An Excel table also provides much of the functionality that you might apply yourself to a data range, but 
it does it all for you with one click. The Excel table provides some consistency with formatting, and makes 
it quick to add all the analysis features you commonly need. This means that you don’t have to think 
about what you need; you just create an Excel table and start working straight away. 
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    Note: Do not confuse Excel tables (previously known as Excel lists) with Excel Data tables. 
They are two different features. This lesson discusses Excel tables. 

Create an Excel Table 

Creating an Excel table in the workbook that 
contains your data is quick and easy. 

Create an Excel Table 
To create an Excel table: 

1. Highlight the data range you want to include 
in the Excel table. 

2. Click Insert, and then click Table. The 
Create Table dialog box appears. 

3. The data range appears in the Where is the 
data for your table? box. If this is not 
correct, click the Data Range icon and highlight the correct data range. 

4. If your data has row titles, click My table has headers. Otherwise leave this clear.  

5. Click OK to create the Excel table. 

Alternatively, click Tell me what you want to do in the menu bar, and select Insert Table. The Create 
Table dialog box appears as described above. You can also select the Home tab, and select Format as 
Table.  

Your data will be formatted as an Excel table. Alternate rows are shaded, making it easier to read across 
wide rows. Filter buttons are added to each column, allowing you to file and sort the data.  

Your data must be in the same workbook, and on the same sheet. The data used to create your Excel table 
cannot itself be an Excel table.  

    Best Practice: Use the CTRL-T keyboard shortcut to create a table from a data range. You 
must have one or more cells selected, and Excel will prompt you to confirm or specify the data 
range.   

Format Your Excel Table 
After you have created an Excel table, you will see that a new tab appears called Table Tools Design. This 
includes options to allow you to format and work with your data. 

To format your Excel table with different colors, click Design, and from the Table Styles group, select an 
alternative color or style. Note that some styles have borders, some shading, and some both borders and 
shading. The styles are grouped into light colors, medium colors, and dark colors.  

Table Style Options 
In the Table Style Options group, you can: 

 Add a Total Row. 

 Select Banded Columns, which shades alternate columns to make the data easier to read.  

 You can keep Banded Rows, which shades alternative rows to make the data easier to read. Although 
you can choose both options simultaneously, using one at a time is probably better.  
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 Embolden the first or last column, which frequently contain row totals, by selecting First Column or 
Last Column. 

Excel Table Tools 
The Tools group allows you to add a slicer, create a pivot table from the data, and remove duplicates. 
Slicers and pivot tables are discussed in Modules 3 and 4. 

Remove duplicates allows you to remove duplicate records, based on the column you specify. Consider a 
marketing manager who wants to create a profile of recent customers. From a data set of customer 
orders, she first filters the orders to only those in the last 12 months. She then removes duplicate 
customer rows based on the CustomerID, so that only one row per customer remains. She can then 
analyze the data based on geography, gender, and other demographic data, knowing that the data will 
not be skewed by having duplicate rows for customers.  

The Tools group contains the option to Convert to Range. This converts the Excel table to a normal 
range of cells. This option retains all the data and formatting, but removes filter buttons and the Design 
tab associated with the Excel tables. Convert to Range removes the Excel table from your workbook, 
without removing the data. You can also right-click the table, click Table, and then click Convert to 
Range. 

Sorting and Filtering 

When you create an Excel table, filters are 
applied to each column. This makes it easy to 
explore large amounts of data. Depending on the 
type of data included in the Excel table, different 
types of filters will be applied: 

Types of Filter 
There are three types of filter that can be applied 
to many different types of columns. These filters 
are mutually exclusive, which means that if you 
apply one type of filter, you cannot apply 
another. Filters do, however, provide a very 
flexible way of filtering your data. 

 Criteria filter. You can use a criteria filter to select between certain values, or rows after or before a 
certain value. You can also apply top n criteria, such as top 10 rows by item or percentage. 

 Format filter. You can use a format filter to select by color, for example. This is useful if you have 
applied conditional formatting to values in a column.  

 List values. If you have a limited number of values within a column, Excel will create a list and allow 
you to select one or more of the entries. This is useful when working with product categories, for 
example, or countries or regions. The values may be character or numeric. 

    Best Practice: Although Excel allows you to enter any value into a cell, you will get the best 
results when you only enter data of one type into a column. For example, a column entitled Date 
should only include date values, and a column entitled Name should only include character 
names. Although Excel will not stop you from entering a date value into a name column, your 
data analysis will be adversely affected.  
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Applying Filters and Sorts 
To apply a filter or sort, click the down arrow on the column heading, and select the filter and sorts you 
require. When you apply a filter to a column, you will see that the filter button changes. Instead of a down 
arrow, a funnel symbol is displayed, and the down arrow is much smaller. This tells you that a filter has 
been applied to that column. 

When you apply a sort to a column, an up or down arrow appears on the button, indicating that you have 
sorted on that column. You can have several filters within one Excel table, but just one sort order. 

If you select both a filter and a sort order on a column, then the button will display both the funnel 
symbol and an up or down arrow, to indicate that both are selected. 

These visual reminders of filters and sort orders help prevent mistakes in data analysis, because you can 
quickly see whether you are working with the full set of data, or a subset. 

For more information about filtering data, see the Office support documentation: 

Filter data in a range or table 

https://aka.ms/sr4cxt 

Sorting 
The filter button also includes an option to sort data. You can sort data in ascending or descending order, 
selected on a particular column. It might be helpful to see customer records in data sequence, with the 
most recent orders first. In this case, select the Date column in your data range, then select the filter 
button, and click Newest to Oldest.  

Alternatively, you might be analyzing sales by product, and want to see the highest valued orders first. In 
this case, select the Revenue column in your data range, then select the filter button, and click Largest 
to Smallest. 

Note how the sort options adapt to the type of data in the column. You can only sort on one column at a 
time. You can also create a custom sort order for more complex algorithms.  

For more information on sorting data, see the Office support documentation: 

Sort data in a range or table 

https://aka.ms/ako6b1 

Demonstration: Using an Excel Table 

In this demonstration, you will see how to create an Excel table, and explore the formatting and filter 
buttons that are added to the data range.  

Demonstration Steps 
Prepare the Environment 

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd.  

2. Start Excel 2016.  

3. Click Blank workbook. 

4. Click File, Open, and open Demo2.xlsx file in D:\Demofiles\Mod02.   
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Create an Excel Table 

1. Examine the data on the sheet named Data. 

2. Click somewhere within the data, then click the Insert tab, and then click Table. The Create Table 
dialog box appears.  

3. Check that the data range is correct, and then click OK. 

4. Note the new formatting, and new filter buttons that have been added. 

Explore the Data Using the Excel Table 

1. To see the distribution of orders over years, click the down filter button next to the Year column 
header. The list shows a summary of the years relating to the customer orders.  

2. Click Select All to remove the selection from all years. Click the box next to 2016, and then click OK. 
Only the orders from 2016 are displayed.  

3. Click the filter button again, click Select All, and then click OK. All records are displayed. 

4. To see which countries are included in the data set, click the filter button next to the Country 
heading. Note the list of countries. 

5. Click Select All to remove the selection from all countries, and then click the box next to France, and 
click OK. Only the orders from French customers are displayed. Note the funnel symbol indicating 
that a filter has been applied. 

6. Click the filter button next to the State heading. Note the list of French regions. Do not make a 
selection. 

7. Click the filter button next to the Country heading. Click Select All to remove the filter, and then 
click OK. Notice that the funnel symbol is no longer displayed. 

8. To find the order with the lowest revenue, click the filter button next to the Revenue heading. 

9. Click Smallest to Largest. Note that the filter button now displays an up arrow, and the rows are 
sorted in Revenue sequence. Scroll down to see the largest revenue amount. 

10. Click the filter button next to the Date heading and click Newest to Oldest. Note that a down arrow 
appears on the filter button, and the up arrow no longer appears on the revenue column. The table 
can only be sorted in one order at a time. Note also that you can only remove the sort order by 
sorting on a different column. The table rows must have a sequence. 

11. With a cell in the table selected, click the Design tab, and click Convert to Range in the Tools group. 
When prompted Do you want to convert the table to a normal range? click Yes. This turns the 
Excel table back into an ordinary data range. 

12. Close the file without saving it. 

Verify the correctness of the statement by placing a mark in the column to the right. 

Statement Answer 

True or false? Excel tables are only useful for formatting columns and rows 
in different colors. 
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Lesson 2 
Excel Functions 

When you get data from another system, or another department, it is not always in the format you want. 
Excel has many different formulas to help you work with data, and make calculations. In this lesson, you 
learn how to add calculated columns to your data set. 

Lesson Objectives 
After completing this lesson, you will be able to: 

 Add a new column to your dataset. 

 Populate the column with a calculation using an Excel formula. 

TEXT Function 

In this section, you will learn how to use the TEXT 
function. You can use the TEXT function to 
format values in different ways.  

Text Function 
The text function enables you to format a value 
in the way you specify. In these examples, C18 is 
the cell containing the data that you want to 
format. 

Use the text function like this: 

The TEXT Function 

=TEXT(cell reference, format code) 

Perhaps you have a column of dates, and you want to display just the year. 

TEXT Function Formatting As Year 

=TEXT(C18, “YYYY”) 

If you want to know which day of the week a certain date was (or will be) enter: 

TEXT Function Formatting As Day 

=TEXT(C18, “DDD”) 
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TEXT Function Format Codes 
When you know how to use the TEXT function, you can use different format codes. Here are some 
examples: 

Formula Result 

=TEXT(C18, “0.0%”) Formats a number as a percentage, such as 45.5%. To format to no 
decimal places, type “0%”. 

=TEXT(C18, “# ?/4”) Formats a number as a fraction; in this case as quarters, such as ¾ or ¼. 

=TEXT(C18,”0000-0000”) Formats a number split into two parts with a hyphen between. You can 
format numbers exactly as you want.  

=TEXT(C18, “DD-MM-
YYYY”) 

Formats a number as a date in the format DD-MM-YYYY. You can take 
any part of the date format to use as you want; for example, “DDD” for 
the day formatted as Mon, Tue, and so on. Or “YY” for the year 
formatted as “15” or “16”. 

 

There are many more formats you can use. For more information about the Text function, including a list 
of popular format codes, see the Office support documentation: 

Text function 

https://aka.ms/ngi052 

IF Function 

You can use the IF function to test for a 
condition, and then return a value based on 
whether the original value complied with the 
condition.  

IF Function 
Suppose the value you want to test is in a column 
named Day of the Week, and it contains the day 
of the week that customers place their order. You 
dispatch every day except Friday, so you write a 
function to test whether or not the order should 
be prepared for dispatch.  

The basic syntax for the IF function is: 

IF Function 

=IF(Condition is True, Do This, Otherwise Do This) 

In this example, you test to see if an order should be prepared for dispatch, based on what day the order 
was placed. 

IF Function to Test for Day of Week 

=IF(C18=”Fri”, “Do not Dispatch”, “Dispatch Order”) 
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You can see that the IF function might be useful in many different situations where you want to automate 
decisions, or prepare data for further analysis. There are occasions, however, when you might want to test 
for more than one condition. You can nest the IF function, but Microsoft have introduced a new function 
called IFS that allows you to test for more than one condition. 

For more information about the IF function, see the Office support documentation: 

IF Function 

https://aka.ms/db4ywq 

IFS Function 
The IF function is used a great deal in Excel, and frequently needs to be nested so that more than one 
condition can be tested. The IFS function is new, and means you can test for more than one condition, 
within the same statement. 

The basic syntax is: 

IFS Function 

=IFS(Test 1, Return if True, Test 2, Return if True, Test 3, Return if True) 

This could be used to make two tests in the product dispatch scenario. If orders are received on Friday, 
you do not dispatch; if orders are received on Thursday, they are dispatched using an Express service, to 
ensure they arrive before the weekend.  

Using the IFS function to make two tests: 

IFS Function 

=IFS(C18 = “Fri”, “Do not Dispatch”, C18 = “Thu”, “Express Service”) 

For more information about the IFS function, see the Office support documentation: 

       IFS function 

https://aka.ms/xtqwt6 

DATEDIF Function 

The DATEDIF function is used to calculate the 
difference between two dates. Although it is a 
legacy function, it is still useful in many 
situations. You might want to calculate 
someone’s age from their birth date; or the 
number of years that a customer has been 
purchasing from you. 

DATEDIF function 
The general syntax for the DATEDIF function is: 

DATEDIF 

=DATEDIF(start_date, end_date,format) 

As with the TEXT function, there are different format codes you can use, such as “Y” to return the number 
of years, “M” to return the number of months, and “D” to return the number of days.  
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You can also use the Excel function TODAY() for either the start date, or the end date. This is helpful if you 
want to calculate the number of days or months before an event. 

For more information on the DATEDIF function, see the Office support documentation: 

DATEDIF function 

https://aka.ms/fyd0xz 
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Lesson 3 
Summarizing Data 

Data is only useful if you can extract meaning from it, and summarizing data can help you do that. You 
need to summarize appropriately, thereby looking “behind” the numbers to appreciate what they mean.  

This lesson considers how to summarize data to make it more understandable. 

Lesson Objectives 
After completing this lesson you will be able to: 

 Explain the importance of summarizing data. 

 Explain appropriate ways of summarizing different types of data. 

 Summarize data in an Excel table using the Total Row. 

About Data Summaries 

Summarizing the data gives you the big picture. 
Faced with a mountain of numbers, a summary 
quickly gives you an idea of what you are looking 
at. Data summaries answer questions such as: 

 How many customers bought from us this 
year? 

 What is the total revenue for the year? 

 What was the average order value this year? 

 What was the highest order value? 

 What was the lowest order value? 

 What variation is there in our data? 

You create data summaries for two primary reasons: 

 To help you understand the data. 

 To communicate the meaning of the data to others. 

Educate Your Audience 
It is helpful to give people the “big picture” first, before going into detail. Although people often need to 
see detailed information, familiarizing them with a summary will help them to understand the information 
that follows. A summary puts detailed information in context.  

Think about a recent news item that included data. Often a headline figure is given, such as “Almost 30 
percent of schoolchildren fail their maths exam”. This number is often purposefully rounded, and designed 
to get across a message. The real number may be 28.49 percent of children in four states, but this is too 
much detail to communicate quickly. A figure of 30 percent is instantly recognizable, memorable, and 
more useful than providing an accurate (but difficult to assimilate) number in the headline. 

In a business setting, not everyone wants the detail. It might be enough to know that sales are 5 percent 
above target, without providing the exact breakdown of sales for the month. 
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Educate Yourself 
Although data summaries are often used when conveying a message about the data, they are just as 
valuable during the analysis phase. You can use them to: 

 Check your work. For example, you might check that an average isn’t greater than the total. 

 Test hypotheses. You might think you know which region is best for performance. You can test this 
idea by creating summary totals on revenue, profit, and then revenue and profit by salesperson for 
each region.  

 Get to know the data. When faced with a large spreadsheet, creating summary totals is a good way 
to understand the data. You may not use all the summary totals in your reports, but by creating 
summaries, you can formulate questions for further analysis. 

 Perform comparisons. For example, calculating totals for different regions, different years, and 
different product ranges, provides a great deal of information, and also forms the basis for further 
investigation. 

Data summaries are an important part of data analysis, both to convey meaning to your audience, and as 
part of your analysis. In the next lesson, you will look at how Excel tables make it easy to create a variety 
of different data summaries.  

Total Row 

You have the option to add a total row to your 
Excel table. This enables you to quickly add 
totals, averages, counts, and other summary 
totals to your data columns.  

The total row includes different options to 
summarize data. The available options for a 
numeric column are: 

 None (no total) 

 Average 

 Count 

 Count numbers 

 Max 

 Min 

 Sum 

 StdDev 

 Var 

 More functions 

SUM 
The most useful function in Excel is the SUM function, which adds together the values in a range of cells. 
Whilst SUM is easy to use, it is not suitable for all columns. Consider the marketing manager who is 
analyzing sales by customer. Creating a total for the revenue column will give her the total sales for the 
year, but this is probably not very useful. The question is not so much “how much revenue did the 
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company generate?” for a particular year, but “what type of customers should the company be marketing to 
in order to maximize revenue?”. To do that, the marketing manager will have to dig a little deeper. 

To use the SUM function, type =SUM(cell range); for example, =SUM(A2: A14). Alternatively, select it 
from the drop-down list in the totals row of an Excel table.  

Average 
The average function returns an average of the numbers within the range you select. An average is the 
total of the numbers contained within the range, divided by the count of those values. If any of the cells 
within your range contain text or are empty, they will be ignored. However, if any of the cells contain 
zeros, they are included. 

You might summarize a number of orders for a customer demographic by calculating the average 
revenue.  This could be contrasted with the average revenue for all customers; for example, the average 
order value for 18- to 25-year-olds is $249, compared with an average order value of $150 for all 
customers in the sample.  

To use the Average function, type =AVERAGE(cell range); for example, =AVERAGE(A2: A12). 

An arithmetical average might not always be what you want to show, so there are two other types of 
average, called a median and a mode.  

 Median is the middle value in a group of numbers, and is calculated in Excel with the function = 
MEDIAN(cell range); for example, =MEDIAN(A2: A12).  

 Mode is the number that appears most often within your range of numbers, and is calculated in Excel 
with the function =MODE.SNGL(cell range); for example, =MODE.SNGL(A2: A12). 

Average is an option within the total row of an Excel table. Although MEDIAN and MODE.SNGL are not 
on the main list when you select the drop-down box on the totals row, select More functions … and then 
Search for a function. Type the name of the function you require, and then select it from the list. Click 
OK when you have selected the function you want to use.  

    Best Practice: The three ways of calculating an average that you have discussed can 
produce very different results, depending on your data. It is good practice to say which 
calculation you have used, particularly if you are not using AVERAGE, which is the most common 
way to calculate an average. Note that AVERAGE (also called mean), MEDIAN, and MODE are all 
legitimate ways of calculating an average. 

Count 
Count gives you the number of items within a range. This is useful to provide a sense of scale. Taking our 
previous example of the average order value, if the number of 18- to 25-year-olds is small when 
compared to the total number of all customers, then the average value will not be helpful. The fact that, 
on average, orders from 18- to 25-year-olds were three times the value of everyone else’s is of little 
concern if only three orders were placed by that age group. The greater the number of values within a 
population, the more helpful a value, such as an average, will be. If you count the number of customers 
you are analyzing, and then count each subgroup, you will provide more context to the other summary 
values that you produce.  

To use the COUNT function in Excel, type =COUNT(cell range); for example, =COUNT(A2:A12). Count 
is provided as an option within the total row of an Excel table. 

Count number gives you a count of the numbers within a column, when text and numbers are in the 
same column.  
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Max and Min 
Max and Min give you the maximum and minimum values within a range. Like COUNT, these provide 
context to your data. Use them to sense-check conclusions, demonstrate variability in your data, or show 
outliers.  

Standard Deviation 
Standard deviation tells you the range within which most (about two thirds) of values lie from the mean. A 
low standard deviation tells you that most of the values are close to the mean, whereas a high deviation 
tells you that most of the values are dispersed far from the mean.  

Consider a situation where you have analyzed your orders for the year: mean order size is 100 and the 
standard deviation is 15. This means that approximately two thirds of your orders were between 85 and 
115. 

Var  
Var is the square of standard deviation and a measure of how spread out your data is.  

    Note: When using StdDev or Var, ensure that all the values in the range represent a 
coherent population such as the same region, the same company, or the same product range. 
When data from different populations are mixed together, the standard deviation or variance is 
likely to be high, and not meaningful. 
In statistical terms, all values should be distributed on a single normal curve. For example, the 
average heights of boys and girls in a class have different normal distributions and different 
mean heights. So that, when boys and girls are measured together, their standard deviations and 
variances are higher than when measured separately. 

Demonstration: Adding a Total Row 

Demonstration Steps 
Prepare the Environment 

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd.  

2. Start Excel 2016.  

3. Click Blank workbook. 

4. Click File, Open, and open Demo2.xlsx file in D:\Demofiles\Mod02.   

5. Click somewhere in the data, click the Insert tab, and then click Table. The Create Table dialog box 
appears.  

6. Check that the data range is correct, and then click OK. 

Add a Total Row 

1. Click somewhere in the table, and from the Design tab, Table Style Options group, select Total 
Row. A totals row is added to the table. 

2. Click the arrow next to the Revenue total. Note this is a SUM of the revenue column. 

3. Select cell N113038 and click the arrow. Select Average from the list. Explain that a total of Cost 
Price values would not be a useful summary, whereas Average is useful. 
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4. Select cell C113038 and click the arrow. Select Count from the list. Explain that this gives a count of 
the records. Note that this is not a count of customers because CustomerIDs may appear more than 
once. 

Combining Filters and Totals 

1. Click the Country Filter and click Select All to clear everything, then click United Kingdom. Click 
OK. Note the reduced number of records. 

2. Select cell K113038 and click the arrow. Select Average from the list. 

3. Click the Country Filter again, clear United Kingdom, and then select Canada. Click OK. Note that 
Canada has a higher average order quantity than the UK. 

4. Close the spreadsheet without saving. 

Real-world Issues and Scenarios 
How many different ways do you summarize data? Totals and averages are commonly used in data 
analysis, but adding further information, such as counts, minimums and maximums, can also be helpful. 
Sorting data in different ways, looking at subsets of the data and making comparisons, can all be helpful 
in getting a better understanding of your data.  
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Lab: Analyzing Customer Demographics 
Scenario 
After receiving the high level sales information, Sindy has asked for some more detailed data. In particular, 
she wants a demographic profile of customers, together with how much they spend. The IT department 
has provided you with some data. You need to analyze the data in time for your meeting with Sindy, first 
thing in the morning. 

Objectives 
After completing this lab exercise, you will be able to: 

 Create an Excel table. 

 Format the data appropriately. 

 Add filters and a total row. 

 Provide summaries based on the data. 

Estimated Time: 45 minutes 

Virtual machine: 10994B-MIA-BI 

User name: Admin 

Password: Pa55w.rd 

Exercise 1: Create an Excel Table 

Scenario 
Sindy wants demographic data about the Adventure Works customers—and she needs it quickly. Luckily, 
the IT department can supply you with a spreadsheet, but you need to analyze it to provide Sindy with 
some conclusions. To get this done quickly, you decide to create an Excel table. 

The main tasks for this exercise are as follows: 

1. Create an Excel Table 

  Task 1: Create an Excel Table 
1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 

Pa55w.rd. 

2. In the D:\Labfiles\Lab02\Starter folder, open Lab02.xlsx. 

3. Create an Excel table from the data. 

4. Note three things provided in Excel tables that help you to analyze data. 

5. Select First Column and Last Column. Note the effect that this has on the table, and think of 
different ways in which you would use this. 

6. Select different styles for the table. Which styles work best, and why? 

7. Add a Total Row to the table, add an average for TotalPurchaseYTD, and format it to zero decimal 
places. 

8. Save the spreadsheet, and leave it open for the next lab exercise. 
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Results: After completing this lab exercise, you will be able to: 

Create an Excel table from data provided to you. 

Add a total row to an Excel table. 

Exercise 2: Work with Excel Table 

Scenario 
After creating an Excel table, you now want to work with the table ready to analyze the data. 

The main tasks for this exercise are as follows: 

1. Format the Data 

2. Calculated Columns 

  Task 1: Format the Data 
1. Format the DateFirstPurchase column as Short Date.  

2. Format the BirthDate column as Short Date. 

  Task 2: Calculated Columns 
1. Insert a new column between DateFirstPurchase and BirthDate and title it MonthFirstPurchase. 

2. In cell D2, calculate the month name for cell C2 using the TEXT function. The column is populated 
with month names. 

3. Insert a new column between MaritalStatus and BirthDate and title it Age. Populate the column 
with the age. 

4. In cell F2, calculate the age for cell E2 using the DATEDIF function. The column is populated with 
ages. 

5. Insert a new column between MaritalStatus and Age and name it AgeGroup. 

6. Use a nested IF statement to calculate which age group each person falls into: 

o < 21 = “Young Person” 

o > 66 = “Mature” 

o Everyone else = “Adult” 

7. Format the Age column to zero decimal places. 

8. Save the spreadsheet, and leave it open for the next exercise. 

 

Results: After completing this lab exercise, you will be able to: 

Format columns within the table. 

Add calculated columns.  
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Exercise 3: Analyze the Data 

Scenario 
Sindy has sent you an email message saying that she will only have 15 minutes available for your meeting. 
She has asked if you could summarize the data for her, so she can quickly understand it in time for her 
meeting with the CEO.  

The main tasks for this exercise are as follows: 

1. Demographics Analysis 

  Task 1: Demographics Analysis 
1. Navigate to D:\Labfiles\Lab02\Starter and open Lab02b.xlsx and Analysis.xlsx. 

2. For each of the calculations below, enter the amounts in the Analysis.xlsx spreadsheet. 

3. Calculate the AveragePurchaseYTD for the following: 

a. Each Yearly Income band 

b. Each Age Group 

c. Each season 

4. Create appropriate charts for each table. 

5. Compare your results with the solution in the D:\Labfiles\Lab02\Solution folder. 

 

Results: After completing this lab exercise, you will be able to: 

Use an Excel table to analyze and summarize data. 

Draw conclusions about the data. 

Question: To what degree did it help to add charts to the analysis? 
 
 

Check Your Knowledge 

Question 

Based on the results of your demographic data analysis, which conclusion is 
correct? 
 

Select the correct answer. 

 Young people are an ideal target market for Adventure Works Cycles. 

 Autumn and Christmas are an ideal time to promote Adventure Works Cycles. 

 Adventure Works should focus on the mature market, because these people 
need to get fit using bicycles. 

 Targeting middle income households is optimal for Adventure Works Cycles. 

 Advertising should be targeted at men, because they are more likely to buy 
bicycles. 
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Module Review and Takeaways 
This module introduced Excel tables, and how you can use them to quickly analyze and summarize data. 
Several Excel functions were introduced, and they were used to create calculated columns to enhance the 
data analysis. You learnt how to filter and sort data, and to create charts from your findings.  

    Best Practice: Use Excel tables to quickly analyze and summarize any data. You can easily 
remove the table by selecting Convert to Range. 
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Module 3 
PivotTables and PivotCharts 
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Module Overview 
PivotTables are one of the most powerful features of Microsoft® Excel®, and for anyone whose job 
includes data analysis, they are an essential tool. PivotTables enable you to quickly organize and analyze 
data, and do more in-depth analysis, because you can work with your data in different ways. 

This module introduces both PivotTables and PivotCharts, showing you how to use them to get more out 
of your data. 

Objectives 
When you have completed this module, you will be able to: 

 Describe what a PivotTable is, and how to use it. 

 Work with PivotTables, including designing your own reports. 

 Create and amend PivotCharts. 

 Use PivotTables and PivotCharts to analyze data. 
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Lesson 1 
PivotTables 

This lesson introduces PivotTables.  

Lesson Objectives 
After completing this lesson, you will be able to: 

 Describe a PivotTable and what it is used for. 

 Create a PivotTable in one of two ways. 

 Work with PivotTables. 

What Are PivotTables? 

A PivotTable is a data analysis tool that helps you 
to summarize data, enabling you to create 
meaningful reports. They are called PivotTables 
because you can change the way you look at 
your data—first one way, then another, as if you 
were pivoting the data. Like Excel tables, 
PivotTables add functionality that makes it easier 
to work with complex or large amounts of data.  

You can create a PivotTable manually, or Excel 
can create a PivotTable based on your data. You 
will learn about each option in the following 
topics.  

Data for a PivotTable 
To create a PivotTable, you need suitable data. The data must be in a tabular format, arranged in columns 
and rows with no blank columns or rows. A good source of data for a PivotTable is an Excel table, as 
discussed in the previous module. As with all tables, you should have only one type of data in a column. 
That means that a column titled Date will only contain formatted date values. A column titled Revenue 
will only contain currency values. And neither column will contain text, symbols, hyperlinks, or anything 
else.  
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Recommended Pivot Tables 

A Recommended PivotTable is one that is 
preconfigured, based on your data. This is a good 
place to start with PivotTables, because it takes 
just a couple of clicks to create a report you can 
work with straight away.  

Creating a Recommended PivotTable 
To create a PivotTable using the Recommended 
PivotTables option: 

1. Select a cell within the data range you want 
to use to create a PivotTable. 

2. Click the Insert tab, and from the Tables 
group, click Recommended Pivot Tables. The Recommended PivotTables gallery is displayed. The 
left-hand pane displays previews of your data in a PivotTable. 

3. Hover over a preview in the left-hand panel to get a description of the PivotTable. The description 
comprises the columns that have been summarized, and how they have been summarized. An 
example might be “Sum of Revenue by Country”, or “Sum of Revenue by Customer Age and Gender”. 
Not all recommended PivotTables will be suitable. 

4. Notice that a dotted line appears around your data range—if this is incorrect, click Change Source 
Data… to define the correct data range. 

5. Click the PivotTable preview you wish to use, and then click OK. The PivotTable will be created on a 
different sheet. 

6. Alternatively, if none of the preview PivotTables meet your needs, click Blank PivotTable to create a 
PivotTable manually. Creating PivotTables is covered in the next topic. 

Exploring a PivotTable 
The PivotTable created using the Recommended PivotTable option is configured according to the preview 
you selected. There are two parts to the PivotTable: 

 Formatted report: including data, filter buttons, and totals. 

 PivotTable Fields: the list of available fields you can add or remove from the report. The column 
headings from your data source are now fields you can use in the PivotTable. 

Also, two new PivotTable Tools menu tabs appear—Analyze and Design. 

Recommended PivotTables are a great way of getting up and running quickly. Almost everything is done 
for you—all you have to do is work with the data.  
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Manually Creating a PivotTable 

This topic considers how to manually create a 
PivotTable from tabular data. The process is 
similar to Recommended PivotTables, but instead 
of the PivotTable report being created, you 
define the layout of the report. This gives you 
many more options in the way you analyze data. 

To Manually Create a PivotTable 
To manually create a PivotTable: 

1. Click somewhere within your data set. 

2. From the Insert tab, click PivotTable. 

3. Check the data range is correct, or click the data range button to select a different data range. 

4. Select where you want to place the PivotTable; you can either create a new worksheet, or place it on 
the existing worksheet. 

5. You also have the option to add the data to a Data Model. You will learn about Data Models in 
Module 6. 

6. Click OK. A blank PivotTable is created. 

Exploring a Blank PivotTable 
A blank PivotTable has two parts: 

 Blank report placeholder: this will contain data when you make your selections. 

 PivotTable Fields: these are the fields that you can use to create your PivotTable. The column 
headings from your data source are now fields that you can use in your PivotTable. 

To create a PivotTable, drag fields into the boxes for Filters, Columns, Rows, and Values. As you move 
fields into each box, the PivotTable is immediately updated. If you make a mistake, or want to see the 
data in a different way, remove the field from a box by clicking and dragging it out of the box. You can 
try lots of combinations before deciding how you want your PivotTable report to look. 

    Best Practice: You are not limited to creating just one PivotTable from a data set. To 
analyze the data from multiple perspectives, you might want to create several PivotTables.  
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Working with PivotTables 

You have looked at two methods of creating 
PivotTables: 

 Create a preconfigured PivotTable using 
Recommended PivotTables. 

 Create a blank PivotTable using PivotTable. 

Whichever method you use, the options available 
for working with PivotTables are the same. In 
both cases, a new menu group is created called 
PivotTable Tools; it has two tabs—Analyze and 
Design. The PivotTable Fields options are the 
same for both. 

This section looks at how to work with PivotTables, including adding and removing fields, and working 
with PivotTable values.  

PivotTable Basics 
PivotTables present data by analyzing something by one or more criteria. For example, populations might 
by analyzed by country. In this simple example, population is the single row value, and the column values 
are the country names: UK, France, USA, China, Angola, and so on. The intersection between population 
and country name is the number of people living in that country. This is a familiar and intuitive way of 
analyzing data. 

Consider the same example, but with the population split into age bands. The rows are now titled “Under-
fives”, “five- to 12-year-olds”, 13- to 21-year-olds”, and so on. Now the intersection gives the number of 
people aged between five and 12-years-old living in the UK, or USA, and so on. This gives a more 
detailed, and more useful analysis of the population of countries. 

In this example, you can either have the countries as columns, or as rows. For analysis purposes, it does 
not matter. However, if there are many countries, and not many age bands, it might be more convenient 
to have the countries listed as rows, and age bands as columns, because people are more used to reading 
down a page than across it.  

PivotTables are elegant because you can easily swap columns and rows, changing how your data is 
presented. This is where the name PivotTable came from—indicating the ease with which data can be 
pivoted, or rotated, in different ways. 

Adding and Removing Columns 
Select a field for column headings by dragging it to the box called Columns. As soon as the field is added 
to this box, the column headings appear in the PivotTable. To remove a field from being a column 
heading, click the field and drag it away from the Column area. 

Adding and Removing Rows 
Select a field for a row heading by dragging it into the Row box. As you have already seen, your choice as 
to whether a field should be a column or row heading will be determined by how many columns or rows 
are needed to display the data—and the emphasis you want to give to different aspects of the data. 

Column or row headings tend to be things like countries, regions, months, years, and so on. If you have 
already created column headings, when you create rows, both the rows and values will be entered into 
the PivotTable. This is because you have defined the intersection between columns and rows.  
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Working with Values 
Values represent the information you are analyzing—for example, the number of people in a country, or 
the revenue generated by month. Drag a value field to the values box and the PivotTable will be 
automatically previewed.  

Demonstration: Creating PivotTables 

Demonstration Steps 
Prepare the Environment 

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd. 

2. Start Excel 2016.  

3. Click Blank Workbook. 

4. Click File, Open, and then open Demo03.xlsx in D:\Demofiles\Mod03. 

Create a Recommended PivotTable 

1. On the Sheet1 tab, click somewhere in the data range. 

2. Click the Insert tab. 

3. Click Recommended PivotTables. The Recommended PivotTables dialog box appears with a list of 
PivotTable options in the left panel. Widen the dialog box to see the full previews. 

4. Click each option to display a preview of the PivotTable in the right panel. 

5. Discuss which PivotTable options are useful, which are not, and why. 

6. Select the first option—Sum of TotalPurchaseYTD by YearlyIncome. Click OK. 

7. Explain each part of the PivotTable: 

o Report 

o PivotTable Fields 

o Quadrant for fields 

8. Click the arrow next to Sum of TotalPurchaseYTD in the Values quarter. 

9. Click Value Field Settings. 

10. In the Summarize value field by list, select Average, and then click OK. 

11. Highlight cells B4 to B9, right-click and select Number Format. Click the Number category, and click 
the Decimal places down arrow twice to format the values to no decimal places, and then click OK. 

12. Drag Gender from the list of PivotTable Fields to the Columns quarter. 

Create a PivotTable Manually 

1. Click Sheet 1 and click somewhere in the data range. 

2. Click the Insert tab, and click PivotTable. 

3. The Create PivotTable dialog box appears. Keep the defaults and click OK. 
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4. Explain each part of the new PivotTable: 

o Blank report 

o PivotTable Fields 

o Empty Quadrant for fields 

5. From the list of PivotTable Fields, drag: 

a. Gender into the Columns quarter 

b. TotalPurchaseYTD into the Values quarter 

c. YearlyIncome into the Rows quadrant 

6. Click the arrow next to Sum of TotalPurchaseYTD in the Values quarter. 

7. Click Value Field Settings. 

8. In the Summarize value field by list, select Average, and then click OK. 

9. Highlight cells B5 to D10, right-click and select Number Format. Click Number, and click the 
Decimal places down arrow twice to format to no decimal places, and then click OK. 

10. Compare the values in this PivotTable with the Recommended PivotTable on Sheet2. 

11. Close the spreadsheet without saving. 

Verify the correctness of the statement by placing a mark in the column to the right. 

Statement Answer 

True or false? You should be careful when 
you use Recommended PivotTable or 
PivotTable, because they are difficult to 
change after they have been created. 
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Lesson 2 
PivotCharts 

You use PivotCharts to create charts that help you and your audience make sense of your data. 
PivotCharts are primarily used to visualize the data in a PivotTable, although you can use them 
independently. Like PivotTables, one of the biggest strengths of PivotCharts is the ease with which data 
can be manipulated in different ways. 

This lesson explores PivotCharts, including what they are, how to create them, and how to format them. 

Lesson Objectives 
After completing this lesson, you will be able to: 

 Understand what a PivotChart is, and when to use one. 

 Recognize the different elements of PivotCharts, and how to work with them. 

 Choose the correct PivotChart for your needs. 

 Format a PivotChart appropriately. 

Introduction to PivotCharts 

PivotCharts are like ordinary Excel charts, but 
with more functionality. The benefits of 
PivotCharts are similar to those of PivotTables: 

Speed. Create a well formatted chart very 
quickly. 

Agility. Change the values for the X and Y axes. 

Presentation. Format many aspects of 
PivotCharts. 

To Create a PivotChart 
1. Highlight the data that will be used to create 

a chart.  

2. Click the Insert tab, and from the Charts group, click PivotChart. The Create PivotChart dialog box 
appears.  

3. Confirm or select the data range, and then select the location for the PivotChart. 

4. Click OK. A blank PivotChart is created. 

When you create a PivotChart, a new set of tabs appears called PivotChart Tools. These are Analyze, 
Design, and Format. These tabs include a great deal of functionality when you work with PivotCharts. The 
next few topics cover this functionality in detail. 

    Best Practice: Like PivotTables, your data must be arranged in tabular format, with no 
blank columns or rows. Ensure you have meaningful column or row headings.  
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PivotChart Elements 

After the chart has been created, you might want 
to change some of its elements. For example, you 
will probably need to alter the title to make it 
more descriptive. Just like regular Excel charts, 
PivotCharts allow you to amend the various 
elements that make up the chart. 

Adding or Removing Chart Elements 
You can add or remove elements from a chart by 
clicking the Chart Elements icon (+ symbol) 
when the chart is selected. A list of chart 
elements appears with a tick against elements 
that are currently displayed on the chart. 

To remove the chart title, for example, click the box next to Chart Title to remove the tick, and the title is 
removed from the chart. If you change your mind, and want the title to appear again, click the box and 
the title box appears. Double-click the title box to amend the text. 

By selecting the chart, and clicking the Chart Elements icon, you can add, remove or amend the 
following chart elements: 

 Axes. Add or remove vertical and horizontal axes. Click the > arrow to choose to have only the 
horizontal, or vertical axis. Click More Options for formatting options, such as the width and color of 
the axis lines. 

 Axis titles. Add or remove axis titles. Click the > arrow to choose only a horizontal or vertical title. 
Click More Options for formatting options, such as the color of the axis title, or alignment. 

 Chart title. Add or remove the chart title. Click the > arrow to select the position of the title, and 
More Options for formatting options, such as the color of the chart title, and text style. 

 Data labels. Add or remove data labels. Click the > arrow to select the position of the data labels. 
Click More Options to format the numbers or borders. 

 Data table. Adds the data values to the chart. Click the > arrow to select with or without legend. 
Click More options to format the borders and fill lines around the data table. 

 Error bars. Add or remove error bars. Click the > arrow to select Standard Error, Percentage or 
Standard Deviation. Click More Options to format the error bars.   

 Gridlines. Adds or removes the gridlines from the chart. Click the > arrow to select the type of 
gridlines you want. Click More Options to format the gridlines. 

 Legend. Adds or removes a legend from the chart. Click the > arrow to select the position of the 
legend. Click More Options to format the legend. 

 Trendline. Adds or removes a trendline. Click the > arrow to select the type of trendline or moving 
average you require. Choose from Linear, Exponential, Linear Forecast, or Two Period Moving 
Average. Click More Options to format the trendline. There are additional trendline options, plus 
options for displaying the trendline. 

The exact options shown depend on the chart type. 

    Note: Note the Add Chart Element icon, located on the Design tab within PivotChart 
Tools. This also allows you to add, remove, and amend chart elements. 
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PivotChart Types 

To best communicate an understanding of the 
numbers you need to choose the best chart type 
for the data, you can create PivotCharts of 
different types, and in different styles. You can: 

 Choose the chart type when you create a 
PivotChart. 

 Change the chart type of an existing 
PivotChart by selecting PivotChart Tools, 
Design tab, Change Chart Type. 

    Note: When you create a PivotTable and 
PivotChart at the same time, you must select the chart type later. You cannot specify the chart 
type when the PivotChart is being created. 

Chart Types 
As with regular Excel charts, you have different chart types available: 

 Column charts 

 Line charts 

 Pie charts 

 Bar charts 

 Area charts 

 Scatter charts 

 Stock charts 

 Surface charts 

 Radar charts 

 Treemap 

 Sunburst 

 Histogram 

 Box & Whisker 

 Waterfall 

In addition, you can create combo charts, which combine more than one chart type.  

To select the correct chart type for your data, think about how visuals represent the data. Although each 
different chart type might technically convey the meaning of the data, some visuals are better than others. 
A pie chart is perfect for showing percentages, providing there are not too many “slices”, making it 
difficult to read. Similarly, a line chart might show a trend better than a column chart. Try out different 
chart types to see which is most appropriate.  
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Chart Style 
After you have selected the right chart type, you can then select a style. Styles include whether the chart 
has a background or not, shading, and other devices. Choosing an appropriate style helps a chart stand 
out, and creates a feeling of consistency if you have lots of charts in your report. 

To select an appropriate style for your chart, select the PivotChart and click the Chart Styles icon 
(paintbrush). Select a style from the gallery.  

    Best Practice: Beware of having too many styles in a report. Keeping the same colorway 
and style throughout a report or presentation helps the reader focus on the message, and not 
the formatting. Too many different colors or styles can be distracting. 

PivotChart Layouts 

PivotChart layouts are a quick way to apply a 
layout to a chart. You have seen how to create a 
PivotChart, and to change the chart type, in 
addition to the various chart elements. 
PivotChart layouts are an even faster way to 
apply layout elements to your chart. 

Apply PivotChart Layout 
To use PivotChart layouts: 

1. Select the PivotChart you created. 

2. Click the PivotChart Tools Design tab. 

3. In the Chart Layouts group, click Quick Layout. 

4. Select the layout you require. 

    Note: All of the options in Quick Layout are available through other menus. Quick Layout 
provides a fast way of creating a chart with your preferred options. 

Demonstration: Creating PivotCharts 

Demonstration Steps 
Prepare the Environment 

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd. 

2. Start Excel 2016.  

3. Click Blank Workbook. 

4. Click File, Open, and open Demo03a.xlsx in D:\Demofiles\Mod03. 
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Create a PivotChart 

1. Click Sheet 2 and click somewhere in the PivotTable. 

2. Click the Insert tab. 

3. Click PivotChart in the Charts group. The Insert Chart dialog box appears.  

4. Select Bar in the left-hand list. Select Clustered Bar in the top panel. Note that not all chart types are 
supported with PivotTable data. Click OK. 

5. Click the Yearly Income filter and click Select All to clear everything. Select 50001 – 75000, 75001 – 
1000000 and greater than 1000000. Click OK. 

6. Click the Gender filter.  

7. Click M to select F. Click OK. 

8. Remove both filters by clicking on the YearlyIncome filter, and then click Select All. Click the Gender 
filter and click Select All. Click OK.  

9. Close the spreadsheet without saving. 

Check Your Knowledge 

Question 

What options are not available when you format 
a PivotChart? 
 

Select the correct answer. 

 Color combinations and monochromatic 
color schemes. 

 Adding a data table. 

 Adding pictures. 

 Adding a trendline. 

 Showing error bars. 
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Lesson 3 
Editing PivotTables and PivotCharts 

You can enhance PivotTables and PivotCharts and improve the analysts’ ability to gain meaningful 
insights by editing your spreadsheets. By adding timelines you can enhance time-based analysis and by 
adding aggregations you can summarize data to make the data more understandable. 

Lesson Objectives 
After completing this lesson, you will be able to: 

 Add a timeline 

 Analyze your data 

Timelines 

A timeline is a type of filter that you can add to a 
PivotTable or PivotChart to help you analyze 
time-related data. Adding a timeline is an 
alternative to adding individual filters to your 
report, and has the advantage that you can easily 
change the granularity of the time period you 
see in the report. 

Consider how often you might need to analyze 
revenue or costs by year or month. Or perhaps 
analyze sales by day of the week. Most 
organizations have a requirement to analyze data 
over time. 

Add a Timeline 
To use a timeline filter your data must include one or more columns with time-related data. 

1. Click somewhere on your PivotTable, or PivotChart.  

2. Click the Analyze tab, and then click Insert Timeline. 

3. The Insert Timelines dialog box appears, displaying time-related fields from your data.  

4. Click to select the fields you want to use. Click OK.  

Using a Timeline 
Having added a timeline to your report, you can now use it to filter what is displayed in the PivotTable 
and PivotChart. Use the top-right down arrow to select the time period you want to use, then use the 
slider bar to narrow or widen the time period you wish to view. To remove the filter, click the funnel icon 
again. 

Using the timeline to view different parts of the data is easy, and ideal to use in presentations or include 
as part of a report. You can move the timeline to wherever you want in the worksheet, and even change 
the size by dragging the sizing handles.  
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Timeline Options 
When you have added a timeline to your worksheet, the Timeline Tools group is added to the menu bar, 
together with the Options tab. Options include: 

 Change the timeline caption.  

 Change the connection to a PivotTable. 

 Change the colorway and style. 

 Position the timeline within the worksheet, and specify the size. 

 Specify the elements shown on the timeline. 

A timeline is a good addition to a PivotTable or PivotChart, because most data contains a time dimension. 

For more information about PivotTable timelines, see the Office support documentation: 

Create a PivotTable timeline to filter dates 

https://aka.ms/a469ld 

Analyzing Data 

Now that you have learnt how to create 
PivotTables and PivotCharts, how can you use 
them to analyze your data? 

Summarizing Values 
You have already seen how PivotTables organize 
information into columns and rows, with a value 
at the intersection of the two. This value, 
however, might be one of a number of different 
summaries.  

Consider a PivotTable analyzing revenue by year 
and customer gender. This analysis might help 
you decide whether your marketing should be more appealing to men or women. But what value will you 
display to help you make that decision? The default is sum of revenue—but how meaningful is this? If the 
total revenue for men is higher than the total revenue for women, what does this tell you? It might be 
something or nothing. Consider instead: 

 Average revenue. This might show that men spend more than women, or vice versa. 

 Count of revenue. This will tell you whether more men place orders than women, or vice versa. 

 Min or max revenue. This might tell you whether men or women are responsible for placing very 
large or small orders. 

In reality, all these numbers might be interesting. You can change the way a value is summarized by 
clicking the down arrow next to the value, and then selecting Value Field Settings. This has two tabs:  

 Summarize Values By. This allows you to choose the type of summary, such as Count, Sum, Average, 
and so on. You can also format the number on this tab. 

 Show Values As. This allows you to make comparisons, such as rankings, or display a percentage of 
another value.  
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Use these options to explore your data. Each summary value provides insight, and poses questions which 
you can try to answer. 

For more information on summarizing values in your PivotTable, see the Office support documentation: 

Create a PivotTable to analyze worksheet data 

https://aka.ms/wx1aw5 

Use PivotTables and PivotCharts Together 
PivotTables and PivotCharts are complementary.  

Demonstration: Add a Timeline 

Demonstration Steps 
Prepare the Environment 

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd. 

2. Start Excel 2016.  

3. Click Blank Workbook. 

4. Click File, Open, and open Demo03b.xlsx in D:\Demofiles\Mod03. 

5. Click the PivotTable tab. 

6. Examine the PivotTable. TerritoryID are column headings, ShipDate are the row headings, and 
SumofTotalDue is the value. 

Add a Timeline 

1. Click the PivotTable Tools Analyze tab. 

2. Click Insert Timeline. Select ShipDate and click OK. 

3. The ShipDate timeline appears on the PivotTable. 

4. Change the time period from months to years. 

5. Select 2012 to 2014 using the slider. Examine the data in the PivotTable. 

6. Change the time period to quarters. Select Q1 to Q4 of 2012 using the slider. Examine the data in 
the PivotTable. 

7. Close the spreadsheet without saving. 

Question: Do you have to analyze time-related data in your work? What particular issues 
arise when working with time-related data? How might the Timeline functionality help? 
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Lab: Creating PivotTables and PivotCharts 
Scenario 
Sindy is settling into her new role as VP of Marketing at the Adventure Works Cycle company. She is 
particularly pleased with the information you have provided so far. As she was leaving the last meeting, 
she asked you for some information that she could look at over the weekend. 

Objectives 
After completing this lab exercise, you will be able to: 

 Create a PivotTable from data provided to you. 

 Create different PivotTable variations from the same data.  

 Create a PivotChart from your PivotTable. 

Estimated Time: 60 minutes 

Virtual machine: 10994B-MIA-BI 

User name: Admin 

Password: Pa55w.rd 

Exercise 1: Create a PivotTable 

Scenario 
Sindy was delighted with the data you presented at the meeting. She apologized for having so little time, 
and asked if you could prepare some data for her to look at over the weekend. You decide to create a 
PivotTable for her, so she can work with the data herself. 

The main tasks for this exercise are as follows: 

1. Create a PivotTable 

2. Create a Different PivotTable 

  Task 1: Create a PivotTable 
1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 

Pa55w.rd. 

2. In the D:\Labfiles\Lab03\Starter folder, double-click Lab3.xlsx to open it. 

3. Create a PivotTable on a new worksheet. 

4. Create a PivotTable with: 

a. Column headings of Year, subdivided by Month 

b. Row headings of Country, subdivided by State 

c. Values of total Revenue 

5. Examine the PivotTable by expanding and collapsing the row and column headings. 

  Task 2: Create a Different PivotTable 
1. In the D:\Labfiles\Lab03\Starter folder, double-click Lab3_2.xlsx to open it. 

2. Create a PivotTable that analyzes revenue by Age Group, subdivided by Customer Age and 
Product Category subdivided by Sub Category. 
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3. Make recommendations to Sindy about marketing. Which Product Category do you recommend for 
marketing, and to which Age Group(s)?  

4. Leave the spreadsheet open for the next lab exercise. 

 

Results: After completing this lab exercise, you will have: 

Created a PivotTable. 

Created a variation on the data. 

Exercise 2: Create a PivotChart 

Scenario 
Having created the PivotTables, you feel confident that Sindy will have enough data to analyze. You still 
have some time, so you decide to add a PivotChart to the spreadsheet. 

The main tasks for this exercise are as follows: 

1. Create a PivotChart 

  Task 1: Create a PivotChart 
1. If you have not completed the last lab exercise, in the D:\Labfiles\Lab03\Starter folder, double-click 

Lab3_3.xlsx to open it. 

2. Click somewhere in the data, then create a PivotChart of the most appropriate type. 

3. Use the filter buttons on the chart to explore the data. 

4. What recommendations would you make to Sindy regarding marketing now? 

 

Results: After completing this lab exercise, you will be able to: 

Create a PivotChart based on PivotTable data. 

Use the PivotChart to filter information. 

Exercise 3: Editing PivotTables and PivotCharts 
The main tasks for this exercise are as follows: 

1. Edit the PivotTable and PivotChart 

  Task 1: Edit the PivotTable and PivotChart 
1. If you have not completed the last lab exercise, in the D:\Labfiles\Lab03\Starter folder, double-click 

Lab3_4.xlsx to open it. 

2. Change Sum of Revenues to Average of Revenues.  

3. Format all the values in the PivotTable to no decimal places. 

4. Add a Customer Gender filter to the PivotChart. 

5. Add a Year filter to the PivotChart. 

6. Add a Data Table to the PivotChart. 

7. Close the spreadsheet without saving. 
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Results: After completing this lab exercise, you will be able to: 

Amend a PivotTable. 

Format a PivotChart. 

Question: Why are PivotTables powerful? 
 
 
 

Question: When would you not create a PivotChart from a PivotTable? 
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Module Review and Takeaways 
In this module, you have learned how to work with PivotTables and PivotCharts. You have seen how quick 
and easy it is to create PivotTables and PivotCharts, and how simple it is to amend them. 

PivotTables are one of the most powerful and flexible features in Excel, so it is worth spending some time 
to get comfortable with using them. 

    Best Practice: Make use of PivotCharts to make data more understandable, and easier to 
work with. 

Review Question(s) 
Question: Do you have data in your work that is suitable for a PivotTable? How will 
PivotTables make working with your data easier? 
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Module Overview 
Microsoft® Excel® dashboards are special reports that visualize data relating to one subject. Dashboards 
typically contain multiple PivotCharts and PivotTables that display summary data related to a specific 
objective. Using slicers and filters, controls can be added to dashboards to enable people viewing the 
dashboard to view different aspects of the data, such as a particular category or region. 

Objectives 
When you have completed this module, you will be able to: 

 Describe what a dashboard is. 

 Understand the benefits of using Excel to create a dashboard. 

 Design and create a dashboard. 

 Add slicers and filters to a dashboard. 

 Use PivotTables and dashboards to analyze data. 
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Lesson 1 
Creating a Dashboard 

Dashboards enable you to visualize data and relationships between sets of data, by displaying only the 
data you are interested in. Dashboards use visual devices to ensure the important aspects of a project or 
objective are not missed. The result is a powerful data reporting tool that enables managers to 
understand key elements of a business or project, at a glance. 

This lesson examines dashboards and some options for data analysis using PivotTables. 

Lesson Objectives 
After completing this lesson, you will be able to: 

 Understand what a dashboard is, and when it is useful. 

 Create a dashboard from constituent components. 

 Understand the purpose of a slicer. 

 Create and link slicers to reports. 

What Is a Dashboard? 

An Excel dashboard is a special type of report 
that contains data, tables, and charts relating to a 
specific objective. Dashboards are named after 
car or aircraft dashboards—the idea being that 
everything you need to know is in one, at-a-
glance report. 

Dashboards should be: 

 Easy to read. They are visual, making good 
use of charts and graphics so you can take in 
information very quickly. Think about a car’s 
fuel gauge. Is the fuel tank full, half full, or 
empty? I don’t want a report that tells me 
the capacity of the tank, how many gallons I bought last time I filled up, and my miles per gallon. 
That might be relevant and interesting, but it doesn’t give the big picture of whether I need to stop at 
the next service station. Similarly in business, dashboards aim to give good visual information at a 
high level, so that corrective action can be taken quickly without someone having to study a report.  

 About one thing. A car dashboard has information about the performance of the car, such as the 
current speed, the amount of fuel in the tank, engine temperature, and so on. A business dashboard 
might be about a business achieving revenue targets, or performance of a project. All the activities 
needed to achieve revenue targets or complete the project are shown on the dashboard.  

 About what’s important. A car dashboard doesn’t show information about whether the carpets are 
clean, or the last time the car was washed. It just contains the important data needed to drive the car. 
Is the engine about to overheat? Is the car about to run out of fuel? Backup information is certainly 
needed, but it belongs on other reports. The dashboard just shows summary information about what 
is critical for success. 
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 Consolidated. A dashboard summarizes the important points from background data. Whilst a lot of 
data is very interesting, dashboards are not designed for providing detail. Other reports can be 
designed to show the background information.  

 On one screen. The dashboard is designed to be seen at a glance—so everything must fit onto one 
screen. The space limitation doesn’t make the car’s dashboard any less effective; if anything, it makes 
it more effective. Designing an Excel dashboard to show critical information on one screen is a good 
discipline that will produce better results. 

 Viewed at a glance. This is obviously important in the car—you should be able to see such things as 
your speed without taking your eyes off the road. Whilst there is no such limitation in business, 
dashboards are designed for busy people with full schedules. A CEO should be able to take one look 
at a dashboard and understand what’s happening with a business, or a project.  

 Up to date. A dashboard should show up-to-date data, without the user having to do anything. Just 
as you would expect a fuel gauge to decrease as you drive, so a business dashboard should reflect the 
latest information. You cannot always show data that’s absolutely up to date. However, it’s a good 
idea to show the date at which the data is up to date somewhere on the dashboard.  

The car analogy is useful when thinking about designing your own dashboard. Although you have more 
options in Excel, without the physical constraints of a car, the test of whether or not the data should be on 
the dashboard is very similar.  

By collecting data together into one place, and displaying it visually, a manager can see everything they 
need to know without having to open many different Excel workbooks. 

Advantages of Excel Dashboards 

Although the idea of a dashboard report is based 
on dashboards in cars or aircraft, you have many 
more options when working with Excel. Creating 
an Excel dashboard is both powerful and flexible 
and allows you to show summary data in an 
attractive way.  

These are some of the advantages of working 
with Excel when creating dashboards:  

 Interactivity. Most dashboards are read 
only—there is only a small amount of 
interactivity. However, with an Excel 
dashboard, you can add filters and slicers to 
change the display. Let’s say a summary chart shows revenue by month for the company but you also 
want to show revenue for one division. You can add a filter or slicer so a user can change the display. 
It’s a good rule, however, that users shouldn’t need to change anything to get the high level 
information they need—all important measures should be displayed without any user interaction.   

 Additional data. In the car, you can’t look behind the dashboard to check whether the fuel gauge 
reading is correct—you have to take it on trust. But with Excel, you can go to another worksheet and 
see the detail, either to check or just to get more information. This makes Excel a good tool for 
creating dashboards—you can show both the big picture and include the detail in other sheets. 

 Easy to alter. You can change the way an Excel dashboard looks, and be responsive to business 
changes. Perhaps you have a new measure you want to add, or perhaps an old measure wasn’t as 
useful as you first thought. You can add the table with the data, and create a suitable graphic.  
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Dashboards use familiar Excel tools. Dashboards don’t use anything you don’t already know about—
the gauges are charts, PivotCharts and Sparklines. The data is held in PivotTables and Excel tables. These 
are all devices you know; a dashboard is simply a powerful way of putting them all together.   

Creating an Excel Dashboard 

To create a dashboard in Excel, you will need to 
create a new workbook. You then need to add at 
least one worksheet. The first worksheet will be 
used to display the dashboard, and additional 
worksheets will hold data in Excel tables and 
PivotTables. You use the data in the additional 
worksheets to create charts and tables on the 
dashboard worksheet. 

Decide What’s Important 
The first, and perhaps the most difficult task, is to 
decide what’s important in achieving the 
objective. You will probably want to talk to 
people within the organization to get a view of what’s important, and what is backup information. You 
will also need to decide where the data will come from, and the frequency with which it is available. 

Some useful questions to ask when deciding what should be included on a dashboard: 

 What is the dashboard designed to do? 

 Who will use the dashboard? 

 How will we know if we are on track to achieve our objective? 

 How will we know if we are not going to achieve our objective? 

 What are the important initiatives that will contribute to achieving our objective? 

 What processes must be followed to achieve our objective? 

 What measures can we use to keep us on track? 

Once you know what data you need, and where it will come from, you can then design your dashboard. 

Decide How to Visualize It 
Dashboards are designed to show all the key pieces of information on one screen. The eye is immediately 
drawn to large and colorful visuals, so you should display the most important information using 
appropriate charts and PivotCharts. You can add detail, such as the date when the information was last 
updated, or where the information came from, in smaller text. 

Group similar things together, such as data relating to revenue, or data relating to products. Grouping is 
an easy way to improve understanding. Even if you need to fit a lot of information into a small area, leave 
enough space between logical groups to make the dashboard easier to use. 

You can then add filters and slicers as appropriate.  
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Add the Data 
You may have some data that is displayed directly on the dashboard, but most of it will be in additional 
worksheets. Dashboards show consolidated and summarized data, rather than the detail. 

Use the data from the additional worksheets to create charts, PivotCharts, and Sparklines on the 
dashboard sheet. You can then either save the workbook as it is, or hide the additional sheets. 

Demonstration: Adding and Moving PivotTables and PivotCharts 

In this demonstration, you will be shown the following tasks: 

 Creating a table. 

 Creating a staging worksheet and PivotTables. 

 Creating a dashboard and adding PivotCharts. 

Demonstration Steps 
Create a Table 

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd. 

2. In the D:\Demofiles\Mod04 folder, double-click Demo4.xlsx to open it. 

3. On the Data worksheet, select cell A1. 

4. On the ribbon, on the Insert tab, click Table. 

5. In the Create Table dialog box, ensure that My table has headers is selected, and then click OK. 

Create a Staging Worksheet and PivotTables 

1. Click the New sheet button. 

2. Right-click Sheet1, click Rename, type Staging, and then press Enter. 

3. On the Staging worksheet, select cell A1. 

4. On the ribbon, on the Insert tab, click PivotTable. 

5. In the Create PivotTable dialog box, in the Table/Range box, type Table1, and then click OK. 

6. From the PivotTable fields, drag: 

a. Revenue to Values. 

b. Customer Gender to Rows. 

7. On the ribbon, on the Analyze tab, click PivotTable; in the PivotTable Name box, type 
SalesByGender. 

8. Select cell H1. 

9. On the ribbon, on the Insert tab, click PivotTable. 

10. In the Create PivotTable dialog box, in the Table/Range box, type Table1, and then click OK. 

11. From the PivotTable fields, drag: 

a. Revenue to Values. 

b. Product Category to Columns. 
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c. Year to Rows. 

12. On the ribbon, on the Analyze tab, click PivotTable, in the PivotTable Name box, type 
YearlySalesByCategory. 

Create the Dashboard and Add PivotCharts 

1. On the Staging worksheet, select cell A1. 

2. On the ribbon, on the Analyze tab, click PivotChart. 

3. In the Insert Chart dialog box, click Pie, then click OK. 

4. Right-click the chart, and click Cut. 

5. Click the New sheet button. 

6. Right-click Sheet2, click Rename, type Dashboard, and then press Enter. 

7. Right-click cell B2, under Paste Options, click Use Destination Theme (H). 

8. Switch to the Staging worksheet. 

9. Select cell H1. 

10. On the ribbon, on the Insert tab, click PivotChart. 

11. In the Insert Chart dialog box, click Column, then click OK. 

12. Right-click the new chart, and click Cut. 

13. Switch to the Dashboard worksheet. 

14. Right-click a cell to the right of the existing chart, under Paste Options, click Use Destination 
Theme (H). 

15. Keep Excel open for the following demonstration. 

Adding a Slicer 

Slicers are visual ways of filtering data, and so are 
useful additions to dashboards. Slicers create a 
friendly user interface for a dashboard, and make 
it interactive.  

Adding a Slicer to a PivotTable 
To add a slicer to a PivotTable: 

1. Select a cell in the PivotTable. 

2. On the Analyze tab on the ribbon, click 
Insert Slicer. 

3. Select the appropriate field or category for 
the slicer, and then click OK. 

4. Drag the slicer to the appropriate position on the worksheet. 

You can also add a field as a slicer by right-clicking the field in the field list of the PivotTable, and 
selecting Add as Slicer.  
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After adding the slicer, you can change the way the slicer is displayed by using the Options tab on the 
ribbon. Visually, you can change the design and coloring of the slicer, and you can use the columns 
setting to control whether the slicer values appear as a vertical list, a horizontal list, or as a grid. 

Connecting Slicers to Multiple PivotTables 
You can also configure a single slicer to affect multiple PivotTables or PivotCharts, when the PivotTables 
or PivotCharts have similar fields. Consider two PivotTables: one shows revenue by product category, the 
other shows revenue by country—yet both PivotTables have a field for year. You can add a slicer for year 
to the first PivotTable, and then connect the slicer to the second PivotTable. When someone selects a year 
on the slicer, both PivotTables will be updated to reflect the selected values. 

To connect an existing slicer to an additional PivotTable or PivotChart: 

1. Select the slicer that you want to apply. 

2. On the ribbon, on the Options tab, click Report Connections. 

3. In the Report Connections dialog box, select the PivotTable or PivotChart you want the slicer to 
affect, and then click OK. 

Slicers or Filters 
You can use either slicers or filters to filter data, because they work in similar ways. Deciding whether to 
use a filter or a slicer is the most suitable option for a given PivotTable or PivotChart. 

Use the following table to compare when to use slicers or filters: 

Slicers Filters 

Slicers are a more obvious 
visual control. 

Filters take up less 
dashboard space. 

Slicers work well when there 
are fewer category values, 
such as “product category”. 

Filters work well when there 
are lots of category values, 
such as “product name”. 

Slicers can affect more than 
one PivotTable or 
PivotChart. 

Filters only work with one 
PivotTable or PivotChart. 

Typically, you would either use a slicer or a filter, but you can configure a field in both. In this case, the 
controls are smart enough to reflect the correct settings, so if a user selects certain years in a filter, they 
are then shown in the slicer—and the other way around.  
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Demonstration: Filtering Data Using a Slicer 

In this demonstration, you will be shown the following tasks: 

 Adding a filter. 

 Adding a slicer. 

 Connecting the slicer to another PivotTable. 

Demonstration Steps 
Add a Filter 

1. Switch to the Dashboard worksheet. 

2. Select the pie chart. 

3. In the PivotChart Fields panel, drag Sub Category to the Filters area. 

4. Click the Sub Category drop-down menu on the pie chart. Show the search box, and show the ability 
to select multiple items from the list. 

Add a Slicer 

1. In the PivotChart Fields panel, right-click Country, and then click Add as Slicer. 

2. Select the slicer object in the worksheet. 

3. On the ribbon, on the Options tab, in the Columns box, type 6, and press Enter. 

4. Drag the width of the slicer object out to make the slicer wider, so the buttons are all shown side-by-
side. 

5. Drag the slicer object so that it is placed above or below both chart objects. 

6. In the slicer object, click Canada. Make sure students can see that only the pie chart changes. 

Connect the Slicer to Another PivotTable 

1. On the ribbon, on the Options tab, click Report Connections. 

2. In the Report Connections (Country) dialog box, select the check box for YearlySalesByCategory, 
and then click OK. 

3. In the slicer object, click Germany. Make sure that students observe that both charts now change 
according to the slicer. 
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Categorize Activity 
Categorize the characteristics of slicers and filters into the appropriate category. Indicate your answer by 
writing the category number to the right of each item. 

Items 

1 More obvious visual control 

2 Occupy less dashboard space 

3 Work well for categories with fewer 
values 

4 Work well for categories with many 
values 

5 Occupy more dashboard space 

6 Less obvious visual control 

7 Can affect more than one 
PivotTable/PivotChart 

8 Can affect one PivotTable or 
PivotChart 

 

Category 1  Category 2 

Slicers  Filters 
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Lesson 2 
Data Analysis in Excel PivotTables 

PivotTables and PivotCharts enable you to start creating dashboards that can show a wide range of data 
in a variety of ways. Visualizing data in this way can make it easier and more accessible. However, simply 
creating PivotTables and PivotCharts from the existing data you have available, is not always enough. 
Sometimes you will need to provide additional data that is not present in the source data, but can be 
calculated from the source data, by using calculated columns or calculated fields. You might also want to 
provide additional ways to visualize some of the data on the dashboard with conditional formatting. 

Lesson Objectives 
After completing this lesson, you will be able to: 

 Add a calculated column to a table. 

 Add a calculated field to a PivotTable. 

 Apply conditional formatting. 

 Understand how to identify anomalies in data. 

Adding Calculated Columns 

There might be occasions when you will want to 
show data that is not present in the original 
table, but can be calculated from the existing 
data. If the additional data you want to analyze 
can be calculated from existing data in the table, 
you can add one or more calculated columns to 
the source table to perform further analysis. 

Add a Calculated Column to a Table 
To add a calculated column to a table: 

1. Select the cell in the header row of the 
column immediately to the right of the 
existing table. 

2. Type the name of the field you want to add (the header name for the new column). 

3. Select the cell below the header row in the new column. 

4. Type =, type the formula for the column (or select the appropriate cells from the rest of the table), 
and then press ENTER. Excel will complete the formula automatically for the other cells in the column. 

5. Optionally, select the formatting options for the new column. 

    Note: When using a formula in a defined table, Excel uses column header references, such 
as [@Revenue]-[@Cost] rather than cell references, such as A2-B2.  
 

    Note: To use the new field in an existing PivotTable, you must refresh the PivotTable. 
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Using Calculated Fields 

There are occasions when adding a calculated 
column to a table does not give you the correct 
results when the data is brought into a 
PivotTable. One example of this is percentages—
if you create a column in your original table to 
calculate a percentage value such as a margin on 
a product (or category), when that table is added 
to the PivotTable or PivotChart, Excel adds all the 
percentage values together to give totals. 
However, this is not the way that individual 
percentage values should be summed up. In 
these scenarios, you can create a calculated field 
in the PivotTable to perform the calculations after the totals for the other fields have been calculated. 

Creating a Calculated Field 
To create a calculated field in a PivotTable: 

1. Select a cell in the PivotTable. 

2. On the ribbon, on the Analyze tab, click the Fields, Items & Sets menu, and then click Calculated 
Field. 

3. In the Insert Calculated Field dialog box, in the Name box, enter the name of the field you want to 
calculate, add fields and operators to the Formula box to make the calculation, and then click OK. 

4. Right-click a cell in the new column, and then click Value Field Settings. 

5. In the Value Field Settings dialog box, click Number Format. 

6. In the Format Cells dialog box, select the correct formatting option for the values in the new column, 
and then click OK. 

7. In the Value Field Settings dialog box, click OK. 

    Note: The new column created from a calculated field will be automatically added to the 
fields and values sections of the PivotTable. 

You cannot “delete” a calculated field from the PivotTable after it has been created, without recreating the 
PivotTable, but you can remove the field from view if you no longer need the values to be shown. 
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Using Conditional Formatting 

You can use conditional formatting to provide 
graphical context and highlights to table cells 
containing values. Conditional formatting is very 
useful when you need to show values in a table, 
but you want to make particularly high or low 
values stand out to the reader in an obvious 
way—or you want to show some level of trend 
information visually by comparing the values in 
the selected column. 

Conditional Formatting Options 
There are several ways in which you can apply 
conditional formatting to a column in a table: 

 Highlighting specific cells with a color when the value matches or meets a threshold. 

 Applying data bars to comparative values. This fills the cell in a color from left to right like a bar chart, 
with higher value cells being filled further to the left. 

 Applying color scales to comparative values will color or shade the cells in a range of different colors 
according to the value; for example, the highest value cells might be red, and the lowest value cells 
green. 

 Adding icons to the cells to indicate how the value compares with others in the column, such as a 
green circle or red triangle. 

Conditional formatting is applied by creating rules for the formatting type and any threshold values you 
require, and then applying the rules to the column data. Multiple rules can be applied if required. 

Applying Conditional Formatting 
This example applies data bars to a range of data: 

1. Highlight the cells in one column that should have data bars applied. 

2. On the ribbon, on the Home tab, click the Conditional Formatting menu, point to Data Bars, and 
then click one of the color options. 

When applying conditional formatting to a PivotTable, you can automatically apply the rule to all cells or 
values on the same type of row (such as category) by adding conditional formatting to one example of 
that cell. You then click the Formatting Options pop-out menu at the right side of the selected cell, and 
select All cells showing “<example value>” for “<Category>”, where <example value> is the name of 
the column and <Category> is the name of the row type field where you want to apply the conditional 
formatting. 

Removing Conditional Formatting 
You can remove conditional formatting by removing the rules applied to the data. To manage the rules 
you have created for conditional formatting: 

1. Select a cell in the table with conditional formatting. 

2. On the ribbon, on the Home tab, click the Conditional Formatting menu, and then click Manage 
Rules. 
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Demonstration: Adding Advanced Dashboard Components 

In this demonstration, you will be shown the following tasks: 

 Create a calculated column; for example, to show profit. 

 Create a calculated column for margin (revenue\profit)—add to PivotTable to show incorrect 
(summed) values. 

 Create calculated field for margin. 

 Add conditional formatting to margin column. 

Demonstration Steps 
Create a Calculated Column 

1. Switch to the Data worksheet. 

2. Select cell P1, type Profit, and then press Enter. 

3. In cell P2, type =[@Revenue]-[@Cost], and then press Enter. Check that all cells in column P are 
automatically completed. 

Add a New PivotTable to Show Profit 

1. Switch to the Dashboard worksheet. 

2. Select an empty cell, then on the ribbon, on the Insert tab, click PivotTable. 

3. In the Create PivotTable dialog box, in the Table/Range box, type Table1, and then click OK. 

4. From the PivotTable fields, drag: 

a. Revenue to Values. 

b. Profit to Values (under Revenue). 
Note: if the Profit field does not appear, on the ribbon, on the Analyze tab, click the 
Refresh button. 

c. Product to Rows. 

Add a Calculated Field for Profit Margin 

1. On the ribbon, on the Analyze tab, click the Fields, Items & Sets menu, then click Calculated Field. 

2. In the Insert Calculated Field dialog box, in the Name box, type Profit Margin, in the Formula box, 
type = Profit/Revenue, and then click OK. 

3. Right-click a cell with a value in the Sum of Profit Margin column, and then click Value Field 
Settings. 

4. In the Value Field Settings dialog box, click the Number Format button. 

5. In the Format Cells dialog box, select Percentage, and then click OK. 

6. In the Value Field Settings dialog box, click OK. 

Adding Conditional Formatting 

1. Select the Sum of Profit Margin cell in the row for All-Purpose Bike Stand. 

2. On the ribbon, on the Home tab, click the Conditional Formatting menu, point to Data Bars, and 
click Green Data Bar. 
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3. In the selected cell, click the Formatting Options drop-down menu, and then click All cells showing 
“Sum of Profit Margin” values for “Product”. 

4. Close Excel, saving any changes. 

Finding Anomalies 

When you are working with a lot of data, it is 
important to ensure that the values make sense, 
and that anomalies have not been entered in the 
source data. Such errors will skew some of the 
report values that you display on your 
dashboard. 

 Look for values that have been calculated 
incorrectly, such as percentage values that 
are added together into the totals column. 

 Sense-check your values. Look for values that 
are either very high or very low—this could 
be valid data, but it should make sense; you 
would not expect the largest volume of sales to come from the smallest regions. Equally, you might 
expect the profit margin for both those regions to be similar. 

 Use tools such as standard deviation to identify values that are a significant departure from the 
mathematical mean of all values. 

For more information on standard deviation, see STDEV function: 

STDEV function 

https://aka.ms/nkfqdn 

Verify the correctness of the statement by placing a mark in the column to the right. 

Statement Answer 

True or false? Once you have added a 
calculated field to a PivotTable, you 
cannot delete it. 
 

 

 
Question: What external factors might you choose to consider when selecting colors when 
you use conditional formatting for emphasis in a dashboard? 
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Lab: Creating a Dashboard 
Scenario 
Sindy, the new VP of Marketing at Adventure Works, now wants to start analyzing some of the data you 
have provided a little more deeply. After using the PivotTables and PivotCharts you created for her 
previously, she wants to see if there are some additional ways to compare the data. 

Objectives 
After completing this lab exercise, you will be able to: 

 Create a dashboard using PivotCharts and slicers. 

 Perform a more detailed analysis using dashboards with calculated fields and conditional formatting. 

Estimated Time: 60 minutes 

Virtual machine: 10994B-MIA-BI 

User name: Admin 

Password: Pa55w.rd 

Exercise 1: Create a Dashboard 

Scenario 
After the PivotTables and PivotCharts you created for her last time, Sindy has asked if you can show more 
information on one sheet, and if you can provide some ways to easily filter all related data. You decide to 
create a dashboard for Sindy. 

The main tasks for this exercise are as follows: 

1. Create a Data Table 

2. Create PivotTables to Support the Dashboard 

3. Create the Dashboard 

4. Add a Slicer to the Charts 

  Task 1: Create a Data Table 
1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 

Pa55w.rd. 

2. In the D:\Labfiles\Lab04 folder, double-click Lab4.xlsx to open it. 

3. Create an Excel table named Table1 using the data in the worksheet. 

  Task 2: Create PivotTables to Support the Dashboard 
1. Create a new worksheet. 

2. On the worksheet, create a new PivotTable from the table data.  

3. From the PivotTable fields, drag: 

a. Revenue to Values. 

b. Country to Rows. 

c. State to Rows (under Country). 

4. Name the PivotTable SalesbyCountry. 
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5. Add another PivotTable to the worksheet, also using Table1 as the source. 

6. From the PivotTable fields, drag: 

a. Revenue to Values. 

b. Product Category to Rows. 

c. Sub Category to Rows (under Product Category). 

7. Name the PivotTable SalesbyCategory. 

  Task 3: Create the Dashboard 
1. Create a PivotChart from the SalesbyCountry PivotTable. Use the pie chart type. 

2. Collapse the fields to only show countries, not states. 

3. Cut the new chart and paste it onto a new worksheet called Dashboard. 

4. Return to the worksheet with the PivotTables. 

5. Create a new PivotChart for the SalesbyCategory PivotTable, using the bar chart type. 

6. Move the bar chart to the Dashboard worksheet. 

  Task 4: Add a Slicer to the Charts 
1. Add a slicer for Year to the pie chart. 

2. Connect the same slicer to the SalesbyCategory PivotChart. 

3. Check that changing the slicer changes both the PivotCharts. 

 

Results: After completing this lab exercise, you will have: 

Created a data table for a dashboard. 

Created PivotTables to support a dashboard. 

Created a dashboard. 

Added a slicer and connected the slicer to two charts. 
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Exercise 2: Performing More Detailed Analysis with Dashboards 

Scenario 
Sindy likes the look of the dashboard you have created, and has found it very useful. However, she has 
raised some questions about the data it contains. Sindy has asked for profit data to be included in the 
analysis, along with a way to visually compare profit margin between different product categories. 

The main tasks for this exercise are as follows: 

1. Add a Calculated Column to the Table 

2. Add a PivotTable to the Dashboard 

3. Add a Calculated Field to a PivotTable 

4. Add Conditional Formatting to a PivotTable 

  Task 1: Add a Calculated Column to the Table 
1. On the Data worksheet, add a column for Profit. Profit is calculated as Revenue minus Cost. 

2. Add another column for Profit Margin. Profit margin is Profit divided by Revenue. 

3. Format the Profit Margin column as a Percentage with two decimal places. 

  Task 2: Add a PivotTable to the Dashboard 
1. Add a new PivotTable to the Dashboard worksheet, using Table1 for the source data. 

2. From the PivotTable fields, drag: 

a. Profit Margin to Values. 

b. Note: if the Profit Margin field does not appear, on the ribbon, on the Analyze tab, click the 
Refresh button. 

c. Product Category to Rows. 

d. Sub Category to Rows (under Product Category). 

3. Do the values in the Profit Margin column appear valid? What issue has occurred with the Profit 
Margin column? 

  Task 3: Add a Calculated Field to a PivotTable 
1. Remove the Profit Margin field from the PivotTable. 

2. Create a calculated field in the PivotTable called Margin. Margin is Profit divided by Revenue. 

3. Set the Margin values to display as a Percentage with two decimal places. 

  Task 4: Add Conditional Formatting to a PivotTable 
1. Add conditional formatting to all the Sub Category rows, using Light Blue Data Bars. 

2. What product subcategory has the lowest profit margin? How could you find out which product has 
the lowest margin? 

3. Close Excel, saving any changes. 

Results: After completing this lab exercise, you will be able to: 

Add a calculated field. 

Add conditional formatting. 
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Question: How could you find out which product has the lowest margin? 
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Module Review and Takeaways 
In this module, you have seen how to create Excel dashboards to help visualize several sets of related data 
at the same time. You also saw how to add tools such as slicers, which enable people to interact with a 
dashboard and view specific aspects of the data. 

Review Question(s) 

Check Your Knowledge 

Question 

You have a PivotTable displaying data that is 
split into more than 50 categories. How would 
you make it easy for a user to focus on a single 
category of the data? 
 

Select the correct answer. 

 Drag the category field to the rows area in 
the PivotTable field options. 

 Drag the category field to the filters area in 
the PivotTable field options. 

 Drag the category field to the values area in 
the PivotTable field options. 

 Drag the category field to the columns area 
in the PivotTable field options. 

 Right-click the category field and select Add 
as Slicer. 
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Module 5 
Hierarchies 

Contents: 
Module Overview 5-1 

Lesson 1: Hierarchies 5-2 

Lesson 2: Time Data 5-7 

Lab: Working with Data Hierarchies 5-11 

Module Review and Takeaways 5-15 

 

Module Overview 
Hierarchies provide convenient levels at which to view your data. If you keep all your sales data by store, 
you might not always want to view the data by each store at a time; sometimes you will want to see a 
summary overview of all store sales in one city, or all store sales in one state, together. It’s important to 
consider the creation of these hierarchies when you are putting together PivotTables, PivotCharts, 
dashboards, and other tools that help people to visualize the data. 

You must also consider what time and date data you have, and how this should be represented. Time and 
date information is stored in a specific way in Microsoft® Excel®—understanding how it is stored, how it 
is represented, and how it can be manipulated, is an important part of preparing your data. 

Objectives 
When you have completed this module, you will be able to: 

 Create and visualize different kinds of data hierarchies, using different field types. 

 Identify and manipulate time and date information in Excel. 
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Lesson 1 
Hierarchies 

Hierarchies are an important way of accessing data in manageable ways, without having too much detail 
when it is not necessary. You can also use hierarchies to provide additional detail when required without 
overloading a user with too much information—so that the user loses focus. Identifying, planning, and 
creating data hierarchies is important when considering who will work with or review your data, tables, 
and charts. 

Lesson Objectives 
After completing this lesson, you will be able to: 

 Identify a data hierarchy. 

 Design hierarchy levels. 

 Identify Excel charts for displaying hierarchies. 

 Identify hierarchy chart requirements. 

What Are Hierarchies? 

Hierarchies represent ways of grouping data that 
fit into larger or smaller categories of the same 
type. An example of a hierarchy might be 
geographic regions: you might want to view sales 
data by country, but within a country, such as the 
United States, you might want to view sales data 
for a state, such as Oregon. Within the state level, 
you might want to view sales data for an 
individual city, such as Portland, or perhaps an 
individual store. These fields or filters (country, 
state, city, store), represent a hierarchy of 
different levels that are all geographic in nature.  

Hierarchies can naturally exist within many aspects of your data, and you might sometimes wish to 
introduce a hierarchy to mask a level of detail that is not immediately necessary. For example, you might 
have some sales data that includes the numeric age of the customer as a discrete value. This could lead to 
perhaps 60 separate discrete values for your table or chart to display. Instead, you might choose to group 
these into ranges of six years each, so that your table or chart has less clutter and only shows 10 initial 
entries, but allows viewers to expand each range to show the discrete values if required. 
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Designing Hierarchy Levels 

Hierarchy levels can be added to your tables and 
PivotTables in several ways. For PivotTables, you 
can add hierarchy levels by adding fields to the 
rows area in the PivotTable Fields panel. You can 
add more than one field to the rows area of the 
PivotTable. Excel automatically indents and 
provides expand/collapse capabilities for each 
additional row you specify after the first row. 
Reorganizing the order of the fields in the rows 
area will control which field is considered at the 
top of your hierarchy, and which fields are lower 
down.  

To create a hierarchy with related levels, you will need the data to have different levels recorded as 
different fields in your source data. This means that a separate column in the source data table is required 
for each level in the hierarchy you want to provide. For example, if you want a geographic hierarchy 
representing country, state, and city, that would require three columns in the source table—a column for 
country, a column for state, and a column for city. The order of the columns in the table is not important 
because the order can be changed when the data is presented in the PivotChart. 

Because Excel handles time and date data differently, separate columns are not always required, and Excel 
might be able to automatically create a time- and date-based hierarchy in a PivotTable or PivotChart. 
Handling time and date data is covered in the next lesson. 

Representing Hierarchies Visually 

Excel 2016 contains two new chart types, called 
Treemap and Sunburst, which are designed to 
represent multiple hierarchical layers of data 
simultaneously.  

Both of these new chart types require that the 
data table is arranged by using a tabular layout, 
and cannot be used with PivotTables at the time 
of writing. 

    Note: Both of these chart types are only 
available to Excel 2016 and later. PivotTable 
support might be added to these chart types in the future. 
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Tabular Layout 
With a tabular layout, each level in the hierarchy is represented by an entry in a separate column. If there 
are three levels in your hierarchy, there would be three columns for the hierarchy elements with additional 
columns for the data itself. The following example shows a tabular layout for the items sold by a grocery 
store: 

Section Category  Subcategory Revenue Profit 

Food Fresh Food Fresh Vegetables  $ 45,098.00   $      18,039.20  

Food Fresh Food Fresh Fruit  $ 39,274.00   $      15,709.60  

Food Fresh Food Prepared Salad  $ 15,689.00   $         6,275.60  

Food Canned Food Canned Vegetables  $ 12,365.00   $         2,473.00  

Food Canned Food Canned Fruit  $ 14,562.00   $         2,912.40  

Food Sauces Pasta Sauces  $ 30,816.00   $      13,867.20  

Food Sauces Curry Sauces  $ 25,649.00   $      11,542.05  

Food Sauces BBQ Sauces  $ 37,462.00   $      16,857.90  

Food Sauces Hot Sauces  $ 15,684.00   $         7,057.80  

Non-food Cleaning Bleach  $ 20,058.00   $         5,014.50  

Non-food Cleaning Detergent  $ 27,462.00   $         6,865.50  

Non-food Cleaning Multisurface  $ 22,897.00   $         5,724.25  

 
Note that the Section, Category, and Subcategory columns are filled in for each row, and there are no 
gaps or empty cells for these categories in the hierarchy.  

Create the Hierarchy Chart 
To create the chart, highlight the table on your worksheet then, on the Insert tab of the ribbon, click 
Recommended Charts. In the Insert Chart dialog box, on the All Charts tab, click Treemap or 
Sunburst, and then click OK. 
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Demonstration: Creating a Treemap Chart 

In this demonstration, you will be shown the following tasks: 

 Creating a PivotTable for structure. 

 Creating a tabular data layout using SUMIFS(). 

 Creating a treemap chart. 

Demonstration Steps 
Create a PivotTable for Structure 

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd. 

2. Open the D:\Demofiles\Mod05\Demo5.xlsx file. 

3. On the Data worksheet, select cell A1. 

4. On the ribbon, on the Insert tab, click Table. 

5. In the Create Table dialog box, ensure that My table has headers is selected, and then click OK. 

6. Click the New sheet button. 

7. On the Sheet1 worksheet, select cell A1. 

8. On the ribbon, on the Insert tab, click PivotTable. 

9. In the Create PivotTable dialog box, in the Table/Range box, type Table1, and then click OK. 

10. From the PivotTable fields, drag: 

a. Revenue to Values. 

b. Product Category to Rows. 

c. Sub Category to Rows (under Product Category). 

11. On the ribbon, on the Design tab, click the Report Layout menu, and then click Show in Tabular 
Form. 

12. On the ribbon, on the Design tab, click the Report Layout menu, and then click Repeat All Item 
Labels. 

13. On the ribbon, on the Design tab, click the Subtotals menu, then click Do Not Show Subtotals. 

14. On the ribbon, on the Design tab, click the Grand Totals menu, and then click On for Rows Only. 

Create a Tabular Data Layout 

1. Select cells A1-C18, right-click the highlighted cells and click Copy. 

2. Select cell E1, right-click cell E1, and under Paste Options, click Values. 

3. Increase the width of columns E, F, and G to clearly display the cell contents. 

4. Highlight cells G2-G18, right-click the highlighted cells, and click Clear Contents. 

5. Select cell G2, type =SUMIFS(Table1[Revenue],Table1[Sub Category],$F2), and then press Enter. 

6. Select cell G2, then click and drag the lower-right corner of the cell down to cell G18 to fill all the 
relevant cells. Check that the value in the filled cells matches the corresponding values in the 
PivotTable. 
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Create a Treemap Chart 

1. Highlight cells E1-G18. 

2. On the ribbon, on the Insert tab, click Recommended Charts. 

3. In the Insert Chart dialog box, on the All Charts tab, click Treemap, and then click OK. 

Question: You have a dataset of sales information by US city that you wish to summarize 
with a hierarchy. Location information is presented in a single column in the format <city 
name>, <state code>—for example, Richmond, VA. How would you need to process the 
data to enable the hierarchy to have city and state levels? 
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Lesson 2 
Time Data 

Time and date information is stored in a very specific way in Excel. This method requires some 
understanding before attempting to manipulate these values, or identify values in user-friendly ways, such 
as days of the week, or months of the year. 

Lesson Objectives 
After completing this lesson, you will be able to: 

 Understand how time and date information is stored in Excel. 

 Identify functions that can manipulate time and date values. 

 Calculate time and date values in Excel. 

Why Is Time Data Different? 

In Excel, time data is stored as a number, starting 
from January 1, 1900, which is represented by the 
number 1. Each day since that date is 
represented by adding 1 to the number—so 2 
would represent January 2, 1900, 3 would 
represent January 3, 1900, and so on. January 1, 
2016 is represented by 42370. When you choose 
to format a cell as a date, Excel will display the 
date represented by the number in a region-
friendly way, such as 01/01/2016 if you choose 
the short date format. 

It is also important to understand that Excel has 
knowledge of the calendar, so Excel knows how many days are in each month, how many days in each 
year, and which days are weekdays or weekends. This enables several powerful function-based capabilities 
when working with dates, such as being able to determine how many days, weeks, or working days there 
are between two given dates. 

Adding Time Data 
Time data is handled in a similar way—if adding 1 to the number representing the date adds one day, 
then effectively 1 also represents 24 hours. This means that 0.5 represents 12 hours, 0.25 represents 6 
hours, 0.041666 represents 1 hour, 0.00069444 represents 1 minute, and 0.00001157407 represents 1 
second. Time values can exist in the same number (and field) as a date; for example, 42370.75 would be 
18.00 on January 1, 2016. 
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Working with Time Data 

Excel has many functions to manipulate date and 
time data, and because the data is stored as a 
number in Excel, incrementing or decrementing 
the date (or time) is easy. For example, if you 
have a shipping date stored in cell C4, and you 
want cell D4 to hold the payment due date—
which is 30 days after the shipping date—you 
would enter the following formula into cell D4: 
=C4+30. 

Functions to Retrieve the Current Date 
and Time 
Excel provides the TODAY function to retrieve 
the current date. If you enter =TODAY() into a cell in the worksheet, Excel will display today’s date 
whenever you open the worksheet. You can also use this function to compare to other dates to determine 
how many days ahead or past a given date is. For example, cell F5 has a future deadline date—in cell G5, 
you enter the following formula: =F5-TODAY() and format cell G5 as a number with no decimal places. 
Cell G5 now tells you how many whole days there are before the deadline date, and will automatically 
refresh the number each time the workbook is opened. 

Excel also provides the NOW function to represent the current date and time. This works in a similar way 
to the TODAY function, but also includes the time value, whereas the TODAY function has the time value 
set to 0 (representing 12:00). 

Determining Weekday, Month, and Year 
If you have been provided date information as a single value, but you want to compare information in 
different months or years, then you might wish to extract the month or year values separately, to use in a 
table or PivotTable. 

To determine the weekday of a date, you can use the WEEKDAY function. For example, to show the 
weekday of a date in cell B5, you can use =WEEKDAY(B5). Note that the value returned by the function is 
also a number: by default, 1 represents Sunday, 2 represents Monday, and so on. 

The MONTH function returns a number that represents the month of a given date, and the YEAR function 
returns the year portion of a date. 

Calculations Based on Working Days Only 
Excel also has functions that are designed to focus only on working days when performing comparisons or 
calculations, and ignore the weekends, for example. 

You can count ahead a number of working days by using the WORKDAY function. If you have a date in 
cell A2 and you want the date in eight working days’ time, you can use the following formula: 
=WORKDAY(A2,8). For countries or regions that define different days as nonworking in the week, you can 
use the WORKDAY.INTL function in a similar way. 

If you need to calculate the number of working days between two given dates, then you can use the 
NETWORKDAYS function. For example, to show the number of working days between a date in cell A2 
and another date in cell B2, you would use the following formula: =NETWORKDAYS(A2,B2). Again, there is 
a NETWORKDAYS.INTL function to calculate working days between two dates where days other than 
Saturday and Sunday are nonworking days of the week. 



Data Analysis Fundamentals Using Excel 5-9 

 

    Note: The WORKDAYS, WORKDAYS.INTL, NETWORKDAYS, and NETWORKDAYS.INTL 
functions can all have additional holidays considered as nonworking days, such as Christmas Day, 
or Thanksgiving, by using advanced options within the respective function. 

Demonstration: Working with Date and Time Data 

In this demonstration, you will be shown the following tasks: 

 Inputting and displaying a date value. 

 Inputting a time value. 

 Adding to a time and date. 

 Using the TODAY() function. 

 Using the MONTH() function. 

 Using the NETWORKDAYS() function. 

Demonstration Steps 
Input and Display a Date Value 

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd. 

2. In Excel, click the New sheet button. 

3. On the Sheet2 worksheet, select cell A1. 

4. In cell A1, type a date in MM/DD/YY, and then press Enter. 

5. Select cell A1. Point out that Excel automatically formats the cell (note the default YYYY format for 
the year value). 

6. On the ribbon, on the Home tab, in the Number drop-down menu, select General. Point out that 
Excel stores a numerical value to represent the date. 

Input a Time Value 

1. Edit cell A1, type .5 at the end of the existing number. 

2. On the ribbon, on the Home tab, in the Number drop-down menu, select More Number Formats. 

3. In the Format Cells dialog box, under Category, click Custom. Under Type, click m/d/yyyy hh:mm, 
and then click OK. 

4. Increase the width of column A to display the contents of cell A1. Point out that the time is now 
visible and shows midday (0.5 representing halfway through the day). 

Adding to a Time and Date 

1. In cell B1, type =A1 + 1.25, and then press Enter. 

2. Point out that Excel has formatted the cell in the same way as cell A1, and the date and time have 
both increased. 

Using the TODAY() Function 

1. In cell A2, type =TODAY(), and then press Enter. 

2. Select cell A1, on the ribbon, on the Home tab, click Format Painter, and then click cell A2. 
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3. Right-click cell B1 and then click Copy. 

4. Right-click cell B2, then under Paste Options, click Paste. 

5. Point out that there is a similar result to the previous example—the time offset has occurred because 
the TODAY() function does not give the current time, but defaults to midnight (00:00) on the given 
date. 

Using the MONTH() Function 

1. In cell C2, type =MONTH(A2), and then press Enter. 

2. Point out that the returned value for month is also a number. 

3. In cell D2, type 
=IF(C2=1,"January",IF(C2=2,"February",IF(C2=3,"March",IF(C2=4,"April",IF(C2=5,"May",IF(C2
=6,"June",IF(C2=7,"July",IF(C2=8,"August",IF(C2=9,"September",IF(C2=10,"October",IF(C2=1
1,"November",IF(C2=12,"December")))))))))))), and then press Enter. 

Using the NETWORKDAY() Function 

1. In cell A3, type =A2+13, and then press Enter. 

2. In cell A4, type =NETWORKDAYS(A2,A3), and then press Enter. 

Check Your Knowledge 

Question 

Which function would you use to get the current 
date and time? 
 
 

Select the correct answer. 

 TODAY() 

 MONTH() 

 NOW() 

 TIME() 

 NETWORKDAYS() 
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Lab: Working with Data Hierarchies 
Scenario 
Sindy was pleased with the dashboard that you created for her and has used the charts to great effect. 
However, she now has some additional questions and tasks for you. Sindy wants to display some 
hierarchical data graphically so she can present it to her team. Sindy wants to display revenue information 
broken down by both gender and age group, but she is not sure how to create the age groups.  

She also wants to break down sales by day across all revenue data, to determine if certain days of the 
week have the slowest sales for Adventure Works products. 

Objectives 
After completing this lab exercise, you will be able to: 

 Create a hierarchy chart from tabular data. 

 Perform analysis by manipulating time and date data. 

Estimated Time: 40 minutes 

Virtual machine: 10994B-MIA-BI 

User name: Admin 

Password: Pa55w.rd 

Exercise 1: Create a Sunburst Chart 

Scenario 
Sindy has seen some examples of a sunburst chart, and would like to use this kind of chart to present 
information to her team. She would like to show revenue by gender further broken down by age 
grouping; however, there are currently no age groups in the data, only the individual ages of customers. 
You should create age groups for Sindy, and then create the chart. 

The main tasks for this exercise are as follows: 

1. Create Age Ranges for the Hierarchy 

2. Create a Tabular Layout of the Data 

3. Create the Sunburst Chart 

  Task 1: Create Age Ranges for the Hierarchy 
1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 

Pa55w.rd. 

2. Open the D:\Labfiles\Lab05\Lab5.xlsx file. 

3. Create an Excel table called Table1 using the data in the worksheet. 

4. Create a new column to the left of the Customer Gender column, titled Age Group. 

5. In the new column, create a formula using nested IF() statements to group customers into the 
following age groups: 

o Under 21 

o 21-29 

o 30-39 
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o 40-49 

o 50+ 

  Task 2: Create a Tabular Layout of the Data 
1. Create a new worksheet called Sheet1. 

2. On the new worksheet, create a PivotTable from Table1, with the following fields: 

a. Revenue under Values. 

b. Customer Gender under Rows. 

c. Age Group under Rows (under Customer Gender). 

d. Product Category under Filters. 

3. Display the PivotTable in tabular layout, repeat the item labels, and remove the column totals. 

4. Copy the PivotTable and paste values only to cell A16. 

5. Clear cells C17-C26. 

6. Enter the following formula to cell C17: =SUMIFS(Table1[Revenue],Table1[Customer 
Gender],$A17,Table1[Age Group],$B17,Table1[Product Category],IF($B$1="(All)","*",$B$1)). 

7. Fill from cell C17 down to cell C26. 

8. In the PivotTable, remove the Revenue, Customer Gender, and Age Group fields. 

9. Delete the intervening cells, so that your recreated table is moved up under the Product Category 
filter. 

  Task 3: Create the Sunburst Chart 
1. Use your newly created table to create a sunburst chart. 

2. Check that the filter control applies to the chart. 

 

Results: After completing this lab exercise, you will have: 

Created age ranges in a hierarchy 

Created a tabular layout of your data 

Created a sunburst chart 
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Exercise 2: Perform Year and Day Data Analysis 

Scenario 
Sindy would like to perform some additional analysis, by using time and date data. She would like to 
compare revenue figures from different years to determine if there has been growth in sales. In addition, 
Sindy would also like to see whether sales of certain categories are different for different days of the week. 

The main tasks for this exercise are as follows: 

1. Create a Tabular Layout of Yearly Sales Data 

2. Isolate the Day of the Week 

  Task 1: Create a Tabular Layout of Yearly Sales Data 
1. Create a new worksheet called Sheet2. 

2. Switch to Sheet2. 

3. Create a PivotTable from Table1, using: 

a. Revenue to Values. 

b. Country to Rows. 

c. Year to Columns. 

4. Copy the PivotTable contents except the totals. 

5. Paste the PivotTable contents as values to cell A12. 

6. Delete the revenue figures, leaving only the structure of the new table. 

7. Name the new table Growth. 

8. Add the following formula to cell C14:  
=(SUMIFS(Table1[Revenue],Table1[Country],$A14,Table1[Year],C$13)-
SUMIFS(Table1[Revenue],Table1[Country],$A14,Table1[Year],B$13))/SUMIFS(Table1[Revenue]
,Table1[Country],$A14,Table1[Year],B$13). 

9. Fill from cell C14 down to C19. 

10. Change the cell formatting to Percentage Style with two decimal places. 

11. Copy the formula from the cells in column C to column D, and to each column for every year. 

12. Create a line chart from the resulting table. 

  Task 2: Isolate the Day of the Week 
1. Switch to the Data worksheet. 

2. Insert a new column after year, called Day. 

3. Add the following formula to cell C2:  
=IF(WEEKDAY([@Date])=1,"Sunday",IF(WEEKDAY([@Date])=2,"Monday",IF(WEEKDAY([@Dat
e])=3,"Tuesday",IF(WEEKDAY([@Date])=4,"Wednesday",IF(WEEKDAY([@Date])=5,"Thursday"
,IF(WEEKDAY([@Date])=6,"Friday",IF(WEEKDAY([@Date])=7,"Saturday"))))))). 

4. Create a new worksheet called Sheet3. 
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5. On Sheet3, create a new PivotTable from Table1, using: 

a. Revenue under Values. 

b. Country under Rows. 

c. Day under Columns. 

6. Create a PivotChart from the PivotTable, using the Column chart type. 

 

Results: After completing this lab exercise, you will have: 

Created a tabular layout of your data 

Isolated weekdays 

Question: Why did the formula to isolate the weekday require the IFS() function? 
 
 
 

Question: Some organizations like to analyze data such as sales on a weekly basis. What 
function in Excel could assist with this kind of analysis? 
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Module Review and Takeaways 
In this module, you have seen how to create hierarchies to present data at different levels, allowing users 
to identify overarching trends or dig deeper into detailed information. You have also seen how to create 
tabular table layouts that support hierarchical charts, such as the sunburst and treemap chart types. And 
you have seen how Excel stores date and time information, and several of the functions available to work 
with time and date values. 

Review Question(s) 
Verify the correctness of the statement by placing a mark in the column to the right. 

Statement Answer 

True or False? Treemap and sunburst 
charts are available in all versions of 
Excel. 
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Module 6 
The Excel Data Model 

Contents: 
Module Overview 6-1 

Lesson 1: Using an Excel Data Model 6-2 

Lesson 2: External Data 6-9 

Lesson 3: Import from CSV 6-13 

Lab: Explore an Excel Data Model 6-16 

Module Review and Takeaways 6-20 

 

Module Overview 
This module introduces Excel Data Models, a way of bringing data from different tables to create a 
relational data source.  

Objectives 
After completing this module, you will be able to: 

 Explain what an Excel Data Model is, and when to use it. 

 Create an Excel Data Model. 

 Understand the relationships in an Excel Data Model. 

 View data in a Data Model, and work with it. 

 Work with external data and Excel Data Models. 
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Lesson 1 
Using an Excel Data Model 

This lesson introduces you to Excel Data Models.  

Lesson Objectives 
After completing this lesson you will be able to: 

 Understand what an Excel Data Model is, and know when to use one. 

 Understand tables and relationships in Excel Data Models. 

 View and work with data in an Excel Data Model. 

What Is an Excel Data Model? 

What Is an Excel Data Model? 
Data Models were introduced with Excel 2013 
and, when it comes to making complex data 
analysis easier, they represent a great step 
forward. For the first time, Data Models bring 
database functionality into a spreadsheet, 
making it possible to relate data tables to each 
other. This is very useful, and means you don’t 
have to worry about functions such as VLOOKUP 
or SUMIF. 

Why Create an Excel Data Model? 
Consider a marketing manager who wants to analyze some data she has collected from her colleagues. 
Each spreadsheet belongs to a different department, and each spreadsheet contains data that is 
potentially useful. By bringing all of this data together into a Data Model, she can link together data that 
relates to the same subject.  

She might have a list of products from the Production department. She creates an Excel table from this 
data and names it Production. She notes that it contains a Product Number, Product Name, Product 
Description and Product Category. The spreadsheet from Accounts contains customer orders, and each 
order contains a Product Number. She creates an Excel table from the Accounts data, and names it 
Orders. Using an Excel Data Model, she can now relate these two tables to each other, using the Product 
Number that is common to both tables. 

    Note: Although you need the Power Pivot in Microsoft® Excel® add-in installed on your 
machine if you want to work with the Data Model directly, you do not need it installed if you are 
just using the Data Model as a source of data.  

If you want to work with the Data Model directly, you must have first installed the Microsoft Office 
PowerPivot for Excel 2013 add-in. You can check whether this add-in is installed by clicking File, then 
Options, and then Add-Ins. A list of all installed add-ins is displayed.  
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For more details about how to install this add-in, see the Microsoft Office documentation: 

Start the Power Pivot in Microsoft Excel add-in 

https://aka.ms/sryhdu  

In the following lessons we will look more closely at how Excel Data Models work. 

For more information about Excel Data Models, see the Office support documentation: 

Create a Data Model in Excel 

https://aka.ms/flhtkg 

Each workbook can contain only one Data Model, but you can use the data from the Data Model in 
multiple worksheets and in multiple places. 

Tables in an Excel Data Model 

Data for an Excel Data Model can come from 
Excel tables or PivotTables that have already 
been created. Excel tables were discussed in 
Module 1 of this course, and PivotTables were 
discussed in Module 3. Both Excel tables and 
PivotTables use data from just one data range. 
But what if you wanted to create a report from 
more than one data range? 

We are now going to see how these tables can 
be combined to create an Excel Data Model.  

    Best Practice: Give Excel tables a name to 
make your Data Model more understandable, and to reduce the possibility of making errors as 
you work. 

Issues with Data 
Data comes from many different sources; sometimes it comes from systems used by other departments. 
Many systems now provide an “Export to Excel” option. When the data is exported, however, it might 
include codes or abbreviations that are used within that system. Product code, department number, and 
management level are all codes commonly used in systems. To create a meaningful and useful report 
from this data, you need to combine more than one table together.  

Create an Excel Data Model with Excel Tables 
First, convert each of your data ranges to an Excel table.  

1. Click the Insert tab, then select the data range. 

2. Click Table to convert the data range to an Excel table. 

3. Name the table by clicking somewhere in the table, and amending the Table Name in the 
Properties group. 

4. Repeat steps 2 to 4 for each data range that you want to include in the Data Model. 
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Second, create a Data Model. 

1. Click the Data tab, and then click Connections in the Connections group. 

2. Click the down arrow on the Add button, and then click Add to the Data Model. The Existing 
Connections dialog box is displayed. 

3. Click the Tables tab, select a table, and then click Open. 

4. A Data Model called ThisWorkbookDataModel is created, with the table name appearing beneath it. 

5. You can add more tables by repeating steps 1 to 4. 

Having created a Data Model, use Workbook Connections to add or remove tables. 

Relationships in an Excel Data Model 

Now that you have added tables to your Data 
Model, you can define relationships between 
them. If you are familiar with databases, you will 
understand how data tables are related to each 
other. Even if you are not familiar with databases, 
this feature is still quite intuitive. In fact, when 
Excel recognizes the relationships between 
tables, it automatically creates the relationships 
for you.  

To create a relationship, the two tables must 
share a common column, for example ProductID, 
CustomerID, or DeptNo. Both columns must 
contain data of the same type—for example, dates in the same format, or currency values—and one of 
these two columns must not contain any duplicate values. This enables Excel to match values from one 
table to another. 

Excel Data Types 
When we work in Excel, we do not normally have to consider data types. We think about how the data is 
presented, not how it is stored. But it is helpful to know a little about how Excel Data Models handles 
data, and the data types it uses. Excel converts data to one of the following data types: 

 Whole numbers: positive or negative numbers with no decimal places; for example, 2983 or -25. 

 Decimal numbers: positive or negative numbers up to 15 decimal places; for example, 322.46. 

 True/False: true or false Boolean value. 

 Text: Unicode character strings up to 268,435,456 Unicode characters. 

 Dates: correctly formatted dates and times after January 1, 1900. 

 Currency: positive or negative numbers up to four decimal places. Allowed values are between  
-922,337,203,685,477.5808 and 922,337,203,685,477.5807. 

 Blank: similar to a SQL null, or DAX blank. 

    Best Practice: It is better not to have blanks or NULLs in your data, although it is 
sometimes unavoidable. If you spot cells that do not contain a value, check to see if the value can 
be completed. 
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You do not need to remember these data types, or the maximum sizes allowed (unless you are working 
with very large values). But be aware that Excel is converting your data to one of these data types. This 
awareness will help you to spot data within a column that has inconsistent data types. 

To learn more about data types, and how to work with them in Excel Data Models, see the Office support 
documentation: 

Data Types in Data Models 

https://aka.ms/blfza8 

Manually Creating a Relationship 
1. On the Data tab, click Relationships in the Data Tools group. The Manage Relationships dialog 

box appears. 

2. Click New. The Create Relationships box appears.  

3. From the drop-down lists, select a Table and a Related Table.  

4. From the drop-down lists, select the column that will match to the related table. The Related 
Column (Primary) is the column with unique values. The Column (Foreign) is the column that 
matches to the Related Column (Primary).  

5. When you have finished, click OK. You will get an error message if one column does not contain 
unique values. 

You can also remove unwanted relationships using Manage Relationships. 

It is not always necessary to manually create a relationship between tables, because Excel can often 
identify the matching data, and create the relationship for you. 

    Note: If you know how to use VLOOKUPs, relationships will be familiar, because the idea is 
the same. You must have columns with matching data so that you can match a value from one 
column to another, thereby accessing the data in that row. 

For more information about creating relationships in an Excel Data Model, see the Office support 
documentation: 

Create a relationship between tables in Excel 

https://aka.ms/cl1o6f 
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Viewing Data in an Excel Data Model 

Once you have created a Data Model, you can 
then view the data through a PivotTable. You 
create the PivotTable in the normal way, but 
instead of selecting a data range, you select the 
Data Model. 

Create a PivotTable from a Data Model 
1. Click somewhere on one of the tables. 

2. Click Insert, then PivotTable. The Create 
PivotTable dialog box appears. 

3. Select Use this workbook’s Data Model. 

4. When the PivotTable is created, you will see that there are fields from all of the tables included in the 
Data Model. 

5. Expand the field list from each table to add to the PivotTable quadrants. 

It is no more difficult to create a PivotTable from a Data Model than it is to create one from a single table. 
However, you can select fields from different tables, keeping the relationships between rows. 

Create Reports from Several Tables 
Data within a database is split into different tables, according to the nature of the data. That means that 
all customer information is in one table, and all information relating to orders is in another. By joining the 
tables together in a Data Model, you can create a report that shows both customers and orders, thereby 
creating a more meaningful report. 

Demonstration: Working with an Excel Data Model 

In this demonstration, you will see how to create a Data Model that contains three tables. 

Demonstration Steps 
Prepare the Environment  

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd.  

2. Start Excel 2016.  

3. Click Blank Workbook. 

4. Click File, Open, and then open the following files from D:\Demofiles\Mod06: 

1. SalesOrderDetail.xlsx 

2. SalesOrderHeader.xlsx 

3. Product.xlsx 

Create Three Tables 

1. Click somewhere in SalesOrderHeader.xlsx then, from the Insert tab, click Table. Click OK to create 
an Excel table. 

2. In the Properties group, rename Table1 to SalesOrderHeader. 
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3. Click somewhere in SalesOrderDetail.xlsx. 

4. Click Insert, and then click Table. Click OK. 

5. In the Properties group, rename Table1 to SalesOrderDetail. 

6. Click somewhere in Product.xlsx and, from the Insert tab, click Table, and then click OK. 

7. In the Properties group, rename Table1 to Product. 

Create a Data Model 

1. From the SalesOrderDetail table, on the Ribbon, click Data, and in the Connections group, click 
Connections. 

2. Click the down arrow next to Add and click Add to the Data Model.  

3. In the Microsoft Excel Security Notice dialog box, click OK. 

4. In the Existing Connections dialog box, click the Tables tab. Select SalesOrderHeader and click 
Open. 

5. ThisWorkbookDataModel appears in the Workbook Connections, with the SalesOrderHeader 
table beneath it. 

6. Repeat steps 2-4 to add the SalesOrderDetail table and then the Product table. All table names will 
appear under ThisWorkbookDataModel. 

7. Click Close. 

Create a PivotTable 

1. Click Insert and PivotTable to display the Create PivotTable dialog box. 

2. Click Use an external data source and click Choose Connection.  

3. Click the Tables tab, and select Tables in Workbook Data Model. Click Open. 

4. The Create PivotTable dialog box now shows the Connection name as ThisWorkbookDataModel. 
Click OK. 

Work with the Data Model 

1. Notice that PivotTable Fields have all tables listed. Expand SalesOrderHeader and drag the 
following field: 

TerritoryID to Columns. 

2. Collapse SalesOrderHeader and expand SalesOrderDetail. Drag the following field: 

LineTotal to Values. 

3. If a Relationships between tables may be needed message appears in the PivotTable Fields 
section, click Close. 

4. Collapse SalesOrderDetail, and expand Product. Drag the following field: 

Name to Rows. 

Create Relationships 

1. In the PivotTable Fields section, note the message Relationships between tables may be needed. 
Click Create. 

2. In Table, select SalesOrderDetail and in Column (Foreign) select SalesOrderID. 
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3. In RelatedTable, select SalesOrderHeader and in Related Column (Primary) select SalesOrderID. 
Click OK. 

4. Click Create again. 

5. In Table, select SalesOrderDetail and in Column (Foreign) select ProductID. 

6. In Related Table, select Product and in Related Column (Primary) select ProductID. Click OK. 

You have created a PivotTable with fields from three separate tables, related together and part of the 
Workbook Data Model. 

7. Close Excel, saving any changes. 

Check Your Knowledge 

Question 

What is the benefit of creating a Data Model? 
 

Select the correct answer. 

 You can create charts more easily. 

 It is easier to work with financial data in Data 
Models. 

 Calculations are performed faster within a 
Data Model. 

 You can create relations between data from 
more than one source. 

 Data Models enable you to create maps 
within Excel. 
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Lesson 2 
External Data 

In this lesson, you will learn how to import data from different data sources, including Microsoft Access® 
and text files. Excel includes extensive functionality to help you work with different data sources, whilst still 
being easy to use. 

Lesson Objectives 
After completing this lesson, you will be able to: 

 Identify the type of data you can import into Excel.  

 Understand the difference between importing data, and linking to external data. 

Importing External Data 

The data you need might not always be in an 
Excel workbook. Sometimes you have to import 
data from a database such as Microsoft SQL 
Server®, or Microsoft Access. Excel makes it easy 
to import data from a wide variety of different 
data sources.   

The Data tab includes a group called Get 
External Data. This group includes options to 
enable you to import data from different sources. 
In this lesson, we will consider each one. 

From Access  
Many organizations hold data in Microsoft Access because it is so quick to set up, and so easy to use. 
Using the Import from Access button, you can import data from tables or views. 

To import data from Microsoft Access: 

1. From the Data tab, and the Get External Data group, click From Access. The Select Data Source 
dialog box appears. 

2. Navigate to the Access database you want to use. Click on the database name (Microsoft Access 
databases have a .mdb extension), and click Open (or double-click the database name). The Select 
Table dialog box appears. 

3. The Select Table dialog box lists all the views and tables in the database. The views appear at the top 
of the list with a different icon (two tables, rather than the single table icon). Select the view or table 
you want to use and click Open (or double-click the name). The Import Data dialog box appears. 

4. Select how you want to import the data, and where in the worksheet you want to put the data. You 
also have the option to Add this data to the Data Model. Make your selections and click OK. 

    Note: What are Views? Views are like tables, but include information from more than one 
table. They are useful because views often include all the information needed for a specific 
purpose.  
As an example, consider a situation where you have three tables that all contain information you 
need. The customer table includes CustomerID and Customer Name. The products table includes 
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ProductID and Product Name. The orders table includes CustomerID, ProductIDs and order 
amount. Although you could work with all three tables separately, a view can join them together 
to include customer name, product name, in addition to order amount. In this case, a view would 
be easier to work with.  
Alternatively, you can add each table to an Excel Data Model. 

For more information about connecting to an Access database, see the Office support documentation: 

Connect an Access database to your workbook 

https://aka.ms/qm2qwx 

From Web 
Some websites include statistics that are useful to add to reports. These include national statistics, and 
data published by government agencies. Such websites offer options to download to .csv or download 
to .xls. However, you can also import direct from a webpage. 

To import from a webpage: 

1. From the Data tab, and the Get External Data group, click From Web. The New Web Query dialog 
box appears. 

2. Copy the URL of the website into the Address box. The webpage appears in the dialog box. Click the 
correct arrow to import a table, or the entire page.  

3. Click Import to import the data into your worksheet. 

From Text 
Data is commonly presented in .csv format (comma separated values). You can import text files in various 
formats using the From Text option. 

To import from a text file: 

1. From the Data tab, and the Get External Data group, click From Text. The Import Text File dialog 
box appears. 

2. Navigate to the text file you want to use. If the text file does not appear, click the down arrow to 
display all text files formats, and select All Files (*.*). 

3. The Text Import Wizard appears. This allows you to specify the format of you file, and how you want 
it to be imported. As you specify the format, you can see a preview of the data. When you are happy 
with the data format, click Finish. 

From Other Sources 
Excel provides an impressive number of options to import data from other sources. There is support for: 

 SQL Server 

 Analysis Services 

 Windows Azure® Marketplace 

 OData data feed 

 XML data  

You can also set up an ODBC connection to connect to Oracle or other data sources.  
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For more information about importing data into Excel, see the Office support documentation: 

Tutorial: Import Data into Excel, and Create a Data Model 

https://aka.ms/agym58 

Copy and Paste 
Whilst not exactly an import option, you can, of course, copy and paste data into an Excel spreadsheet. 
This is sometimes the quickest and simplest solution. You can copy data from a wide variety of sources, 
and for the most part, Excel makes a good job of handling it.  

Linking to External Data 

As an alternative to importing data into your 
spreadsheet, you can link to external data. This 
has the advantage that if the data changes, it will 
be updated in your spreadsheet. You can decide 
how frequently to refresh the data. 

Data Connections 
Data connections enable you to access external 
data. The data connection describes where to 
find the data, log in, and access the data. Once 
you have created the connection, you can also 
refresh the data to get the latest changes and 
import the data into your workbook. 

Create a Data Connection 
In this example, we create a data connection to a Microsoft Access file. 

1. From the Data tab, click From Access. 

2. Navigate to the Access file you want to connect to. You will be prompted to select a table or view. 

3. Select the table or view you require. The Import Data dialog box is displayed. 

4. Select Only Create Connection and click OK. 

5. Click Existing Connections to view the connection. The new connection is displayed. 

6. To work with the data in your workbook, click Open.  

7. The Import Data dialog box is displayed. Click OK to import the data into your workbook. 

View Data Connections 
1. Click the Data tab, and in the Connections group, click Connections. 

2. Click Add. The Existing Connections dialog box is displayed. 

Data connections can be stored within a specific workbook, or on your computer.  

For more information about data connection, see the Office support documentation: 

Create, edit, and manage connections to external data 

https://aka.ms/lp1lbp 
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You can also link data to a Data Model, for more information, see the Office support documentation:  

Add worksheet data to a Data Model using a linked table 

https://aka.ms/pwxfpu  

Verify the correctness of the statement by placing a mark in the column to the right. 

Statement Answer 

Importing or linking external data to your 
Data Model is a deprecated feature. 
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Lesson 3 
Import from CSV 

One of the most common data formats you will come across is a CSV file. It stands for “comma separated 
values”—because each value is separated by a comma. It is a plain text file, which means that it can be 
read by most software applications, including Excel.  

Lesson Objectives 
After completing this lesson, you will be able to: 

 Recognize the format of a CSV file. 

 Import a CSV file into Excel. 

Import a CSV File 

As one of the most commonly used data formats, 
it is useful to be able to import CSV files into 
Excel. When it’s in an Excel spreadsheet, the data 
can be used in the same way as any other Excel 
data. 

CSV File Format 
Although the name CSV, or comma separated 
value, suggests that the values are always 
separated by a comma, this is not the case. A 
comma may be used, but there is the problem 
that data might include a comma. The first line of 
an address, for example, might be formatted as 
“23, Acacia Avenue”. Unless the comma is enclosed in quotation marks to indicate that it is a real comma, 
and not a separator, the data cannot be parsed correctly. 

To get around the problem of “real” commas, data can be separated using other symbols, commonly a 
bar (|) or a tab. Excel copes with these, in addition to other options. 

Import a CSV File 
To import a CSV file into Excel: 

1. Click the Data tab, and in the Get External Data group, click From Text. 

2. Navigate to the CSV file and click Import. The Text Import Wizard opens. 

3. Select the Delimited file type.  

4. Specify the row number to import records from. 

5. Specify the file origin. Most will be Windows (ANSI). 

6. Specify whether or not the data has a header row. 

7. Review the data in the preview window and click Next. 

8. Specify the delimiter used in the file. This may be tab, semicolon, comma, a space, or another 
symbol. 
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9. Specify the text qualifier. This is the charter used to enclose values in a file, such as “—to enclose a 
real comma. 

10. Select whether your delimiter has two characters together. In which case, select Treat consecutive 
delimiters as one. 

11. Review the data in the preview window and click Next. 

12. Select the column data format for each column individually. 

13. The Advanced options allow thousands of separators to be specified. If not specified, your country 
defaults will be used. 

14. Click Finish.  

15. The Import Data dialog box appears. You can specify where the data should be located, and whether 
it should be added to an existing Data Model. Click OK to import the data. 

Inspect the data to ensure it has been imported correctly. For more information about using the Text 
Import Wizard, see the Office support documentation: 

Text Import Wizard 

https://aka.ms/cjnixf 

For more information about importing CSV files into Excel, see the Office support documentation: 

Import or export text (.txt or .csv) files 

https://aka.ms/m1ttq3 

Demonstration: CSV Import Demo 

Demonstration Steps 
Prepare the Environment  

1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 
Pa55w.rd.  

2. Start Excel 2016.  

3. Click Blank Workbook. 

4. Click File, Open, Browse, then in the All Excel Files list, click All Files (*.*). 

5. Navigate to the D:\Demofiles\Mod06 folder, and double-click the Customers.csv file.  

6. The Text Import Wizard is displayed. 

7. Click Delimited, and then click My data has headers. 

8. Inspect the data in the Preview window. Click Next. 

9. From the Delimiters list, click Other and type | (bar). Deselect Tab. 

10. Inspect the data in the Preview window. Click Next. 

11. Format the BirthDate column as Date, then in the list, click YMD. 

12. Click Finish. 

13. The Import Data dialog box appears. Click OK. 
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14. Inspect the data to ensure it has imported correctly. 

15. Close the spreadsheet without saving any changes. 
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Lab: Explore an Excel Data Model 
Scenario 
Sindy has become more enthusiastic about working with the data you have provided. You decide to 
create a Data Model for her, so she can explore the data. 

Objectives 
After completing this lab, you will be able to: 

 Add tables to a Data Model. 

 Create relationships between the tables. 

 Add external data to the Data Model. 

 View the Data Model through a PivotTable. 

Estimated Time: 60 minutes 

Virtual machine: 10994B-MIA-BI 

User name: Admin 

Password: Pa55w.rd 

Exercise 1: Add Multiple Tables 

Scenario 
Sindy is delighted with how things are progressing, and has requested some more in-depth data to work 
with. You decide to create a Data Model, along with some existing Excel tables. 

The main tasks for this exercise are as follows: 

1. Add Tables to a Data Model 

  Task 1: Add Tables to a Data Model 
1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 

Pa55w.rd. 

2. Navigate to the D:\Labfiles\Lab06\Starter folder and open: 

a. SalesOrderDetail.xlsx 

b. SalesOrderHeader.xlsx 

c. Product.xlsx 

Create Three Excel Tables 

 Create an Excel table with the data in each spreadsheet. Name the table with the name of the file 
(without the extension). 

Create a Data Model 

1. Add all the tables to a Data Model. Hint: use Data, Connections. 

2. When you have added all three tables, click Close. 

3. Leave the spreadsheets open for the next lab exercise. 
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Results: After completing this lab exercise, you will be able to: 

Add tables to a Data Model. 

Exercise 2: Create Relationships 

Scenario 
You have created a Data Model with three tables. Each table has a key column that links the data in that 
table, to data in another table. In this exercise, you will create relationships  

The main tasks for this exercise are as follows: 

1. Create Relationships Between Tables 

  Task 1: Create Relationships Between Tables 
Create Relationships 

1. Create a relationship between the SalesOrderDetails table and the SalesOrderHeader table, using 
the SalesOrderID. 

2. Create a relationship between the SalesOrderDetail table and the Product table, using the 
ProductID.  

3. Check the relationships in Manage Relationships. 

4. Leave the spreadsheets open for the next lab exercise. 

 

Results: After completing this lab exercise, you will be able to: 

Create relationships between tables in an Excel Data Model. 

Exercise 3: Add External Data 

Scenario 
Sindy has specifically requested that demographic data be included in the data you provide for her. You 
can only get this data in a CSV file. You need to import the data into Excel, and add it to the Data Model.  

The main tasks for this exercise are as follows: 

1. Import Customers.csv 

2. Add Customers to the Data Model 

3. Add a Relationship 

  Task 1: Import Customers.csv 
1. Create a new workbook and import Customers.csv. 

2. Check the data when it has been imported. 

3. Create an Excel table from the Customer data. Rename the table to Customers. When prompted if 
you want to remove external connections, click Yes. 

4. Leave the spreadsheets open for the next lab exercise. 
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  Task 2: Add Customers to the Data Model 
1. Add the Customers table to the Data Model. 

2. Check that the Data Model now contains four tables. 

3. Leave the spreadsheet open for the next lab exercise. 

  Task 3: Add a Relationship 
1. Create a relationship between the Customers table and the SalesOrderHeader table. 

2. Leave the spreadsheets open for the next lab exercise. 

 

Results: After completing this lab exercise, you will be able to: 

Import a CSV file into Excel. 

Add the table to your Data Model. 

Exercise 4: Create a PivotTable 

Scenario 
You have created a Data Model and added four tables to it, including one with imported CSV data. You 
now want to create a PivotTable so that you can explore the data from all four tables. 

The main tasks for this exercise are as follows: 

1. Create a PivotTable 

2. Create a PivotTable Report 

  Task 1: Create a PivotTable 
1. Using the SalesOrderDetail.xlsx file, create a PivotTable using the Data Model as the data source. 

2. When the PivotTable is created, check that the PivotTable fields include the four tables in your Data 
Model. 

3. Leave the file open for the next lab exercise. 

  Task 2: Create a PivotTable Report 
1. Create a PivotTable report using the following fields: 

a. Column heading of Education from the Customers table. 

b. Row heading of Name from the Product table. 

c. Value of LineTotal from the SalesOrderDetail table. 

d. Filter of TerritoryID from the SalesOrderHeader table. 

2. Explore the PivotTable report. 

3. Close all the spreadsheets without saving. 

Results: After completing this lab exercise, you will be able to: 

Create a PivotTable based on a Data Model. 

Create a PivotTable report based on data from several related tables. 
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Question: Is it necessary to name the Excel tables? 
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Module Review and Takeaways 
In this module, you have learned how to create Data Models from Excel files, in addition to working with 
external data. You have seen how you can relate tables to each other using a common key to make richer 
and more meaningful reports. 

    Best Practice: Requesting source data, and relating data together in a Data Model, gives 
you the power to do more complex analysis. Excel Data Models give you the power of a 
database, and the ease of using Excel. 

Practice using Data Models so you become comfortable with how they work. This will give you more 
power to work with different types of data.  

Review Question(s) 
Question: How will you use Excel Data Models in your work? 
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Course Evaluation 

 
Your evaluation of this course will help Microsoft understand the quality of your learning experience. 

Please work with your training provider to access the course evaluation form. 

Microsoft will keep your answers to this survey private and confidential and will use your responses to 
improve your future learning experience. Your open and honest feedback is valuable and appreciated. 
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Module 1: Reporting in Excel 

Lab: Presenting Data in Charts 
Exercise 1: Filtering Excel Data 

  Task 1: Filter Data 
1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 

Pa55w.rd. 

2. In the D:\Labfiles\Lab01\Starter folder, double-click Lab1.xlsx to open it. 

3. Find the data titled Revenue by Territory, and click somewhere in the data range.  

4. Click the Data tab, and then the Filter icon in the Sort & Filter group. Filter buttons appear on the 
column headings. 

5. Click the Filter button on the Name column, and click the Select All box to clear all the boxes. 

6. Select the following countries, and then click OK: 

a. France  

b. Germany 

c. United Kingdom 

7. Repeat steps 5 and 6, this time selecting regions in the USA: 

a. Central 

b. Northwest 

c. Southwest 

d. Southeast 

e. Northeast 

8. Repeat steps 5 and 6, this time selecting regions in the rest of the world: 

a. Australia 

b. Canada 

9. Remove the filter from the data by clicking the Filter icon again. 

10. If you have time, practice adding a filter to the Revenue by Year data. 

11. Remove the filter from the Revenue by Year data. 

12. Save the spreadsheet and leave it open for the next lab exercise. 

 

Results: After completing this exercise, you will be able to: 

Identify the data you need for your report. 

Filter the data based on your requirements. 
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Exercise 2: Formatting Excel Data 

  Task 1: Formatting Data 
1. Locate the data titled Revenue by Year. Identify the different types of numbers in this data range: 

a. Values in C4 to H6.   

b. Totals in I4 to I7, and C7 to I7. 

c. Percentages in J4 to J6, and C8 to H8.  

2. None of these numbers are formatted, making the data range difficult to understand and analyze. 

3. Select the range C4 to H6.  

4. Click the Currency icon in the Number group. All the values are formatted to two decimal places 
with a currency symbol. 

5. In the Number group, click the Decrease Decimal icon twice, to format the numbers to no decimal 
place. 

6. Select the range C7 to H7. These are totals for each year. Repeat steps 4 to 5 to format the values as 
currency to no decimal places.  

7. Select the range I4 to I7. Format these cells as currency to no decimal places, and make them bold. 

8. Select the range C8 to H8. In the Number group, click the Percent icon. 

9. Select the range J4 to J6 and format as Percentages. 

10. Format the values in Revenue by Category as currency to two decimal places. 

11. Format the values in Revenue by Territory as number to two decimal places. 

12. Save the spreadsheet and leave it open for the next lab exercise. 

 

Results: After completing this lab exercise, you will be able to: 

Identify data that is not formatted correctly. 

Format numeric data appropriately. 
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Exercise 3: Creating Excel Charts 

  Task 1: Create Charts 
1. Select the data range B11 to C15, click Insert and in the Charts group, select Recommended 

Charts. 

2. Click each of the previews in the left-hand panel to show how the data would look with each chart 
type. Select the pie chart type, and then click OK.  

3. Drag the pie chart to the right side of the spreadsheet.  

4. Select the data range B3 to H6, click the Insert tab, and in the Charts group, click the Column icon, 
and then click Clustered Column. 

5. Drag the clustered column chart to a location under the pie chart. 

6. Click somewhere in the Revenue by Territory data range. 

7. Click the Data tab, and in the Sort and Filter group, click the Filter icon. 

8. Click the Filter button on the Name column, click Select All to clear everything, and then select the 
USA territories: 

a. Central 

b. Northeast 

c. Northwest 

d. Southeast 

e. Southwest 

9. Click OK. 

10. Select the data range C22 to D29, click the Insert tab, and in the Charts group, click the Column 
icon, and then click Clustered Bar. 

11. Position the bar chart next to the clustered column chart. 

12. Save the spreadsheet and leave it open for the final lab exercise.  

  Task 2: Formatting Charts 
1. Click somewhere on the Revenue by Territory chart.  

2. Double-click the chart title and overtype Revenue by Territory. 

3. Click Chart Elements (+) and select Data Table to show the values under the chart. 

4. Click Chart Elements (+) again, and select Trendline to show a trendline on the chart. 

5. Click somewhere on the Revenue by Year chart. 

6. Double-click the chart title and overtype Revenue by Year. 

7. Click Filter and clear 2011 and 2012. Click Apply. 

8. Click Chart Styles, and then click Color. Select the orange monochromatic colorway. 

9. Click somewhere on the Revenue by Category chart. 

10. Click the accessories slice of the pie and drag it out a little to give it emphasis. 

11. Click the clothing slice of the pie and drag it out a little to give it emphasis. 
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12. Click Chart Styles and choose the style that shows percentage values in white on each slice. 

13. Click Chart Styles, and then click Color. Select the orange monochromatic colorway to match the 
Revenue by Year chart. 

14. Save your changes and compare your spreadsheet with the one in the Solution folder. 

 

Results: After completing this lab exercise, you will be able to: 

Choose an appropriate chart for your data. 

Create a chart. 

Format a chart. 
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Module 2: Excel Tables 

Lab: Analyzing Customer Demographics 
Exercise 1: Create an Excel Table 

  Task 1: Create an Excel Table 
1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 

Pa55w.rd. 

2. In the D:\Labfiles\Lab02\Starter folder, double-click Lab02.xlsx to open it. 

3. Click somewhere in the data, then click the Insert tab, and click Table. 

4. Make a note of three things Excel tables provide that help you to analyze data. 

5. On the Design tab, select First Column. What affect does selecting First Column have? When might 
you use this? 

6. On the Design tab, select Last Column. What effect does selecting Last Column have? When might 
you use this?  

7. On the Design tab, select a different style for the table. Which styles are most suited to the data, and 
why? 

8. On the Design tab, select Total Row to add a total row to the table. 

9. In the total row, add the following: 

a. TotalPurchaseYTD – Average. 

b. On the Home tab, and the Number group, click the Decrease Decimal until no decimal places 
are displayed. 

10. Save the spreadsheet, and leave it open for the next lab exercise. 

 

Results: After completing this lab exercise, you will be able to: 

Create an Excel table from data provided to you. 

Add a total row to an Excel table. 
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Exercise 2: Work with Excel Table 

  Task 1: Format the Data 
1. Click the heading DateFirstPurchase to select the column.  

2. From the Home tab, and the Number group, select the Short Date format.  

3. Click the heading BirthDate to select the column, and format it as a Short Date by repeating step 2. 

  Task 2: Calculated Columns 
1. Highlight the BirthDate column, then from the Home tab, and the Cells group, click Insert. Select 

Insert Sheet Columns from the list. A new column is inserted. 

2. Double-click the column heading and type MonthFirstPurchased. 

3. In cell D2 type =TEXT(C2, "MMMM"). The month of the first purchase is displayed in the column. 

4. Highlight the MaritalStatus column, right-click and select Insert. A new column is inserted.  

5. From the Home tab, and the Number group, select the Number format.  

6. Double-click the heading of the new column and name it Age. 

7. In cell F2, type =DATEDIF(E2,TODAY(),"Y"). The age is displayed in the column. 

8. Highlight the MaritalStatus column, right-click and select Insert. A new column is inserted.  

9. Double-click the heading of the new column and name it AgeGroup. 

10. In cell G2, type =IF(F2<21, "Young Person", IF(F2 >66,"Mature", "Adult")). 

11. Highlight the Age column and from the Home tab, Number group, click Decrease Decimal twice to 
format the column to zero decimal places.  

12. Save the spreadsheet, and leave it open for the next exercise. 

 

Results: After completing this lab exercise, you will be able to: 

Format columns within the table. 

Add calculated columns.  
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Exercise 3: Analyze the Data 

  Task 1: Demographics Analysis 
1. Navigate to D:\Labfiles\Lab02\Starter and open Lab02b.xlsx and Analysis.xlsx. 

2. Filter on the YearlyIncome column to calculate the AveragePurchaseYTD for yearly income of: 

a. Less than 25,000 

b. 25001 to 50000 

c. 50001 to 75000 

d. 75001 to 1000000  

e. Greater than 1000000 

3. Enter the average purchase YTD for each band in the Analysis.xlsx spreadsheet. 

4. Filter on the MonthFirstPurchase column to calculate the AveragePurchase YTD for each season: 

a. Jan, Feb and Mar (Winter) 

b. Apr, May and Jun (Spring) 

c. Jul, Aug, and Sep (Summer) 

d. Oct, Nov, and Dec (Autumn) 

5. Enter the average purchase YTD for each band in the Analysis.xlsx spreadsheet. 

6. For each table, highlight the data range and on the Insert tab, in the Charts group, select an 
appropriate chart type to create a chart. 

7. Save your spreadsheet and compare it with the solution in the D:\Labfiles\Lab02\Solution folder. 

 

Results: After completing this lab exercise, you will be able to: 

Use an Excel table to analyze and summarize data. 

Draw conclusions about the data. 
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Module 3: PivotTables and PivotCharts 

Lab: Creating PivotTables and PivotCharts 
Exercise 1: Create a PivotTable 

  Task 1: Create a PivotTable 
1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 

Pa55w.rd. 

2. In the D:\Labfiles\Lab03\Starter folder, double-click Lab3.xlsx to open it. 

3. Click somewhere in the data, then click Insert, and then click PivotTable. Click OK.  

4. From the list of PivotTable fields, drag the following: 

a. Country field to the Rows quarter 

b. State field to the Rows quarter (below the Country field) 

c. Year field to the Columns quarter 

d. Month field to the Columns quarter (below the Year field) 

e. Revenue field to the Values quarter 

5. Examine the PivotTable by expanding and collapsing the column and row headings. 

  Task 2: Create a Different PivotTable 
1. In the D:\Labfiles\Lab03\Starter folder, double-click Lab3_2.xlsx to open it. 

2. Click somewhere in the data, then click Insert, and then PivotTable. Click OK. 

3. From the PivotTable fields, drag: 

a. Age Group to Rows 

b. Customer Age to Rows (under Age Group) 

c. Product Category to Columns 

d. Sub Category to Columns (under Product Category) 

e. Revenue to Values 

4. Which is the best-selling Product Category? 

5. Which Age Group(s) would you recommend targeting the marketing to? 

6. Leave the spreadsheet open for the next lab exercise. 

 

Results: After completing this lab exercise, you will have: 

Created a PivotTable. 

Created a variation on the data. 



L3-2 Data Analysis Fundamentals Using Excel 

 

Exercise 2: Create a PivotChart 

  Task 1: Create a PivotChart 
1. If you have not completed the last lab exercise, in the D:\Labfiles\Lab03\Starter folder, double-click 

Lab3_3.xlsx to open it. 

2. Click somewhere in the data, click Analyze, and then click PivotChart. View each of the chart 
previews, then select Clustered Column and click OK. 

3. Use the filter buttons on the chart to explore the data. 

4. What recommendations would you make to Sindy regarding marketing now? 

 

Results: After completing this lab exercise, you will be able to: 

Create a PivotChart based on PivotTable data. 

Use the PivotChart to filter information. 

 

Exercise 3: Editing PivotTables and PivotCharts 

  Task 1: Edit the PivotTable and PivotChart 
1. If you have not completed the last lab exercise, in the D:\Labfiles\Lab03\Starter folder, double-click 

Lab3_4.xlsx to open it. 

2. Click Sum of Revenues in Values, select Value Field Settings, and then Average. Click OK. 

3. Highlight cells B6 to E10. On the Home tab, click Decrease Decimal in the Numbers group until the 
values appear to no decimal places. 

4. Drag the Customer Gender field to Filters. 

5. Drag the Year field to Filters. 

6. With the PivotChart selected, click Chart Elements and select Data Table. 

7. Close the spreadsheet without saving. 

 

Results: After completing this lab exercise, you will be able to: 

Amend a PivotTable. 

Format a PivotChart. 
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Module 4: Dashboards 

Lab: Creating a Dashboard 
Exercise 1: Create a Dashboard 

  Task 1: Create a Data Table 
1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 

Pa55w.rd. 

2. In the D:\Labfiles\Lab04 folder, double-click Lab4.xlsx to open it. 

3. On the Data worksheet, select cell A1. 

4. On the ribbon, on the Insert tab, click Table. 

5. In the Create Table dialog box, ensure that My table has headers is selected, and then click OK. 

  Task 2: Create PivotTables to Support the Dashboard 
1. In Excel, click the New sheet button. 

2. On the Sheet1 worksheet, select cell A1. 

3. On the ribbon, on the Insert tab, click PivotTable. 

4. In the Create PivotTable dialog box, in the Table/Range box, type Table1, and then click OK. 

5. From the PivotTable fields, drag: 

a. Revenue to Values. 

b. Country to Rows. 

c. State to Rows (under Country). 

6. On the ribbon, on the Analyze tab, click PivotTable, in the PivotTable Name box, type 
SalesbyCountry. 

7. Select cell H1. 

8. On the ribbon, on the Insert tab, click PivotTable. 

9. In the Create PivotTable dialog box, in the Table/Range box, type Table1, and then click OK. 

10. From the PivotTable fields, drag: 

a. Revenue to Values. 

b. Product Category to Rows. 

c. Sub Category to Rows (under Product Category). 

11. On the ribbon, on the Analyze tab, click PivotTable, in the PivotTable Name box, type 
SalesbyCategory. 

  Task 3: Create the Dashboard 
1. On the Sheet1 worksheet, select cell A1. 

2. On the ribbon, on the Analyze tab, click PivotChart. 

3. In the Insert Chart dialog box, click Pie, then click OK. 

4. In the lower right of the new chart, click the Collapse Entire Field button. 
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5. Right-click the chart, and click Cut. 

6. Click the New sheet button. 

7. Right-click Sheet2, click Rename, type Dashboard, and then press ENTER. 

8. Right-click cell B2, under Paste Options, click Use Destination Theme (H). 

9. Switch to the Sheet1 worksheet. 

10. Select cell H1. 

11. On the ribbon, on the Insert tab, click PivotChart. 

12. In the Insert Chart dialog box, click Bar, then click OK. 

13. Right-click the new chart, and click Cut. 

14. Switch to the Dashboard worksheet. 

15. Right-click a cell to the right of the existing chart, under Paste Options, click Use Destination 
Theme (H). 

  Task 4: Add a Slicer to the Charts 
1. Select the pie chart. 

2. In the PivotChart Fields panel, right-click Year, and click Add as Slicer. 

3. On the ribbon, on the Options tab, click Report Connections. 

4. Select the check box for SalesbyCategory, and then click OK. 

5. On the slicer, click 2015, and check that both charts change values. 

 

Results: After completing this lab exercise, you will have: 

Created a data table for a dashboard. 

Created PivotTables to support a dashboard. 

Created a dashboard. 

Added a slicer and connected the slicer to two charts. 
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Exercise 2: Performing More Detailed Analysis with Dashboards 

  Task 1: Add a Calculated Column to the Table 
1. Switch to the Data worksheet. 

2. Select cell P1, type Profit, and then press ENTER. 

3. In cell P2, type =[@Revenue]-[@Cost] and then press ENTER. Check that all cells in column P are 
automatically completed. 

4. Select cell Q1, type Profit Margin, and then press ENTER. 

5. In cell Q2, type =[@Profit]/[@Revenue], and then press ENTER. 

6. Highlight column Q, then on the ribbon, on the Home tab, in the Number section, click the General 
drop-down menu, and then click Percentage. 

  Task 2: Add a PivotTable to the Dashboard 
1. Switch to the Dashboard worksheet. 

2. Select an empty cell, then on the ribbon, on the Insert tab, click PivotTable. 

3. In the Create PivotTable dialog box, in the Table/Range box, type Table1, and then click OK. 

4. From the PivotTable fields, drag: 

a. Profit Margin to Values. 
Note: if the Profit Margin field does not appear, on the ribbon, on the Analyze tab, click 
the Refresh button. 

b. Product Category to Rows. 

c. Sub Category to Rows (under Product Category). 

5. Do the values in the Profit Margin column appear valid? What issue has occurred with the Profit 
Margin column? 

  Task 3: Add a Calculated Field to a PivotTable 
1. In the PivotTable Fields panel, clear the Profit Margin check box. 

2. On the ribbon, on the Analyze tab, click the Fields, Items & Sets menu, then click Calculated Field. 

3. In the Insert Calculated Field dialog box, in the Name box, type Margin. In the Formula box, type 
= Profit/Revenue, and then click OK. 

4. Right-click a cell with a value in the Sum of Margin column, and then click Value Field Settings. 

5. In the Value Field Settings dialog box, click the Number Format button. 

6. In the Format Cells dialog box, select Percentage, and then click OK. 

7. In the Value Field Settings dialog box, click OK. 

  Task 4: Add Conditional Formatting to a PivotTable 
1. Select the Sum of Margin cell in the row for Bike Racks. 

2. On the ribbon, on the Home tab, click the Conditional Formatting menu, point to Data Bars, and 
click Light Blue Data Bar. 

3. In the selected cell, click the Formatting Options drop-down menu, and then click All cells showing 
“Sum of Margin” values for “Sub Category”. 
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4. What product subcategory has the lowest profit margin? 

5. Close Excel, saving any changes. 

 

Results: After completing this lab exercise, you will be able to: 

Add a calculated field. 

Add conditional formatting. 
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Module 5: Hierarchies 

Lab: Working with Data Hierarchies 
Exercise 1: Create a Sunburst Chart 

  Task 1: Create Age Ranges for the Hierarchy 
1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 

Pa55w.rd. 

2. In the D:\Labfiles\Lab05 folder, double-click Lab5.xlsx to open it. 

3. On the Data worksheet, select cell A1. 

4. On the ribbon, on the Insert tab, click Table. 

5. In the Create Table dialog box, ensure that My table has headers is selected, and then click OK. 

6. Select cell E1. 

7. Right-click cell E1, point to Insert, then click Table Columns to the Left. 

8. Select cell E1, type Age Group, and then press Enter. 

9. Select cell E2, type =IF([@[Customer Age]]<21,"Under 21",IF([@[Customer Age]]<30,"20-
29",IF([@[Customer Age]]<40,"30-39",IF([@[Customer Age]]<50,"40-49","50+")))), and then press 
Enter. The Age Group column should now be populated with age group labels. 

  Task 2: Create a Tabular Layout of the Data 
1. In Excel, click the New sheet button. 

2. On the Sheet1 worksheet, select cell A1. 

3. On the ribbon, on the Insert tab, click PivotTable. 

4. In the Create PivotTable dialog box, in the Table/Range box, type Table1, and then click OK. 

5. From the PivotTable fields, drag: 

a. Revenue to Values. 

b. Customer Gender to Rows. 

c. Age Group to Rows (under Customer Gender). 

d. Product Category under Filters. 

6. On the ribbon, on the Design tab, click the Report Layout menu, and then click Show in Tabular 
Form. 

7. On the ribbon, on the Design tab, click the Report Layout menu, and then click Repeat All Item 
Labels. 

8. On the ribbon, on the Design tab, click the Subtotals menu, then click Do Not Show Subtotals. 

9. On the ribbon, on the Design tab, click the Grand Totals menu, and then click On for Rows Only. 

10. Select cells A3-C13, right-click the highlighted cells and click Copy. 

11. Select cell A16, right-click cell A16, and under Paste Options, click Values. 

12. Highlight cells C17-C26, right-click the highlighted cells, and click Clear Contents. 
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13. Select cell C17, type =SUMIFS(Table1[Revenue],Table1[Customer Gender],$A17,Table1[Age 
Group],$B17,Table1[Product Category],IF($B$1="(All)","*",$B$1)), and then press Enter. 

14. Select cell C17, click and drag the lower-right corner of the cell down to cell C26 to fill all the relevant 
cells. Check that the value in the filled cells matches the corresponding values in the PivotTable. 

15. Select cell A3. In the PivotTable Fields panel, clear the Age Group, Customer Gender, and 
Revenue fields to remove them from the PivotTable (this will also remove the PivotTable, except for 
the filter). 

16. Highlight rows 3-15, right-click the highlighted rows, and then click Delete. 

17. Adjust the width of columns A, B, and C so that the column values can be seen easily. 

  Task 3: Create the Sunburst Chart 
1. Highlight cells A3-C13. 

2. On the ribbon, on the Insert tab, click Recommended Charts. 

3. On the Insert Chart dialog box, on the All Charts tab, click Sunburst, then click OK. 

4. Change the product category filter to ensure that the chart changes accordingly. 

 

Results: After completing this lab exercise, you will have: 

Created age ranges in a hierarchy 

Created a tabular layout of your data 

Created a sunburst chart 

 

Exercise 2: Perform Year and Day Data Analysis 

  Task 1: Create a Tabular Layout of Yearly Sales Data 
1. In Excel, click the New sheet button. 

2. On the Sheet2 worksheet, select cell A1. 

3. On the ribbon, on the Insert tab, click PivotTable. 

4. In the Create PivotTable dialog box, in the Table/Range box, type Table1, and then click OK. 

5. From the PivotTable fields, drag: 

a. Revenue to Values. 

b. Country to Rows. 

c. Year to Columns. 

6. Select cells A1-G8, right-click the highlighted cells and click Copy. 

7. Select cell A12, right-click cell A12, and under Paste Options, click Values. 

8. Highlight cells B14-G19, right-click the highlighted cells, and click Clear Contents. 

9. Select cell A12, type Growth, and press Enter. 
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10. Select cell C14, type =(SUMIFS(Table1[Revenue],Table1[Country],$A14,Table1[Year],C$13)-
SUMIFS(Table1[Revenue],Table1[Country],$A14,Table1[Year],B$13))/SUMIFS(Table1[Revenue]
,Table1[Country],$A14,Table1[Year],B$13), and then press Enter. 

11. Select cell C14, then click and drag the lower-right corner of the cell down to cell C19 to fill all the 
relevant cells.  

12. With cells C14-C19 still highlighted, on the ribbon, on the Home tab, click Percent Style. 

13. With cells C14-C19 still highlighted, on the ribbon, on the Home tab, click the Increase Decimal 
button twice. 

14. With cells C14-C19 still highlighted, right-click the highlighted cells, and click Copy. 

15. Select cell D14, right-click cell D14, and under Paste Options, click Paste. 

16. Repeat step 15 for each year’s column. 

17. Select cell A1. In the PivotTable Fields panel, clear the Year and Country fields to remove them from 
the PivotTable. 

18. Right-click column B, and then click Hide. 

19. Highlight cells A13-G19, then on the ribbon, on the Insert tab, click Recommended Charts. 

20. In the Insert Chart dialog box, on the All Charts tab, click Line, and then click OK. 

  Task 2: Isolate the Day of the Week 
1. Switch to the Data worksheet. 

2. Right-click cell C1, point to Insert, and then click Table Columns to the Left. 

3. Select cell C1, type Day, and then press Enter. 

4. Select cell C2, type 
=IF(WEEKDAY([@Date])=1,"Sunday",IF(WEEKDAY([@Date])=2,"Monday",IF(WEEKDAY([@Dat
e])=3,"Tuesday",IF(WEEKDAY([@Date])=4,"Wednesday",IF(WEEKDAY([@Date])=5,"Thursday"
,IF(WEEKDAY([@Date])=6,"Friday",IF(WEEKDAY([@Date])=7,"Saturday"))))))), and then press 
Enter. 

5. Click the New sheet button. 

6. On the Sheet3 worksheet, select cell A1. 

7. On the ribbon, on the Insert tab, click PivotTable. 

8. In the Create PivotTable dialog box, in the Table/Range box, type Table1, and then click OK. 

9. On the ribbon, on the Analyze tab, click Refresh. 

10. From the PivotTable fields, drag: 

a. Revenue to Values. 

b. Country to Rows. 

c. Day to Columns. 

11. On the ribbon, on the Insert tab, click Recommended Charts. 

12. In the Insert Chart dialog box, on the All Charts tab, click Column, and then click OK. 
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Results: After completing this lab exercise, you will have: 

Created a tabular layout of your data 

Isolated weekdays 



L6-1 

 

Module 6: The Excel Data Model 

Lab: Explore an Excel Data Model 
Exercise 1: Add Multiple Tables 

  Task 1: Add Tables to a Data Model 
1. Ensure the 10994B-MIA-BI virtual machine is running, and then log on as Admin with the password 

Pa55w.rd. 

2. In the D:\Labfiles\Lab06\Starter folder, double-click each of the following spreadsheets to open 
them: 

a. SalesOrderDetail.xlsx 

b. SalesOrderHeader.xlsx 

c. Product.xlsx 

Create Three Excel Tables 

1. Click somewhere in SalesOrderHeader.xlsx. From the Insert tab, click Table, and then click OK to 
create an Excel table. 

2. On the Ribbon, click the Design tab, in the Properties group, and rename Table1 to 
SalesOrderHeader. 

3. Click somewhere in SalesOrderDetail.xlsx. 

4. Click Insert, click Table, and then click OK. 

5. On the Ribbon, click the Design tab, then in the Properties group, rename Table1 to 
SalesOrderDetail. 

6. Click somewhere in Product.xlsx, from the Insert tab click Table, and then click OK. 

7. On the Ribbon, click the Design tab, then in the Properties group, rename Table1 to Product. 

Create a Data Model 

1. From the SalesOrderDetail table, click Data, and in the Connections group click Connections. 

2. Click the down arrow next to Add and click Add to the Data Model. The Existing Connections 
dialog box appears. 

3. Click the Tables tab. Select SalesOrderHeader and click Open. 

4. ThisWorkbookDataModel appears in the Workbook Connections, with the SalesOrderHeader table 
beneath it. 

5. Repeat steps 2 and 3 to add the SalesOrderDetail table, and then the Product table. All three table 
names will appear under ThisWorkbookDataModel. 

6. Click Close. 

7. Leave the spreadsheets open for the next lab exercise. 

 

Results: After completing this lab exercise, you will be able to: 

Add tables to a Data Model. 
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Exercise 2: Create Relationships 

  Task 1: Create Relationships Between Tables 
Create Relationships 

1. From the SalesOrderDetails table, click the Data tab, and Relationships. The Manage 
Relationships dialog box is displayed.  

2. Click New and in Table select SalesOrderDetail, and in Column (Foreign) select SalesOrderID. 

3. In Related Table, select SalesOrderHeader and in Related Column (Primary) select SalesOrderID. 
Click OK. 

4. Click New again. 

5. In Table, select SalesOrderDetail and in Column (Foreign) select ProductID. 

6. In Related Table, select Product and in Related Column (Primary) select ProductID. Click OK. 

7. Check the relationships and then click Close. 

8. Leave the spreadsheets open for the next lab exercise. 

 

Results: After completing this lab exercise, you will be able to: 

Create relationships between tables in an Excel Data Model. 

 

Exercise 3: Add External Data 

  Task 1: Import Customers.csv 
1. Click File, New, Blank workbook. Select cell A1. 

2. On the Ribbon, click Data, Get External Data, From Text, and navigate to 
D:\Labfiles\Lab06\Starter, then select Customers.csv. Click Import.   

3. The Text Import Wizard is displayed. 

4. Click Delimited, and then click My data has headers. 

5. Inspect the data in the Preview window. Click Next. 

6. From the Delimiters list, click Other and type | (bar). Deselect Tab. 

7. Inspect the data in the Preview window. Click Next. 

8. Using the horizontal scroll bar, select the BirthDate column, then in the Column data format list, 
select Date and select YMD. 

9. Click Finish. 

10. The Import Data dialog box appears. Click OK.  

11. Inspect the data to ensure it has imported correctly. 

12. Save the workbook as MyCustomers.xlsx. 

13. Click somewhere in the data, on the Ribbon click Insert, and then click Table. 

14. The Create Table dialog box appears. Click OK.  
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15. A warning appears: Your selection overlaps one or more external data ranges. Do you want to 
convert the selection to a table and remove all external connections? Click Yes. 

16. On the Ribbon, click Design, then in the Properties group, rename the Table Name to Customers. 

17. Leave the spreadsheets open for the next lab exercise. 

  Task 2: Add Customers to the Data Model 
1. Select SalesOrderDetail.xlsx and on the Data tab, select Connections. 

2. Click the down arrow next to Add. Click Add to the Data Model. 

3. In the Microsoft Excel Security Notice dialog box, click OK. 

4. Click Tables and select the Customers table. Click Open. 

5. Check that the Data Model now contains four tables, and click Close. 

6. Leave the spreadsheet open for the next lab exercise. 

  Task 3: Add a Relationship 
1. Select SalesOrderDetail.xlsx. 

2. On the Data tab, click Relationships. Click New. 

3. In Table, select SalesOrderHeader. In Column (Foreign) select CustomerID. 

4. In Related Table select Customers. In Related Column (Primary) select CustomerID. 

5. Click OK. 

6. Check the relationships and click Close. 

7. Leave the spreadsheets open for the next lab exercise. 

 

Results: After completing this lab exercise, you will be able to: 

Import a CSV file into Excel. 

Add the table to your Data Model. 

 

Exercise 4: Create a PivotTable 

  Task 1: Create a PivotTable 
1. Select SalesOrderDetail.xlsx. 

2. On the Insert tab, click PivotTable. The Create PivotTable dialog box is displayed. 

3. Select Use an external data source. 

4. Click Choose Connection. The Existing Connections dialog box is displayed. Click Tables and select 
Tables in Workbook Data Model. Click Open. 

5. The Create PivotTable dialog box displays the Connection name as ThisWorkbookDataModel. Click 
OK. 

6. A PivotTable is created with PivotTable fields from the four tables in your Data Model. 

7. Leave the file open for the next lab exercise. 
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  Task 2: Create a PivotTable Report 
1. Use the PivotTable you created in the last lab exercise, then create a report using the following fields: 

a. From Customers, drag the Education field to Columns. 

b. From Product, drag the Name field to Rows. 

c. From SalesOrderDetail, drag the LineTotal to Values. 

d. From SalesOrderHeader, drag the TerritoryID field to Filters. 

2. Explore the PivotTable report to see how the fields from all tables work together. 

3. Close all the spreadsheets without saving. 

 

Results: After completing this lab exercise, you will be able to: 

Create a PivotTable based on a Data Model. 

Create a PivotTable report based on data from several related tables. 
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